summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2017-10-12 12:22:55 -0500
committerWilliam Hubbs <williamh@gentoo.org>2017-10-12 12:23:26 -0500
commit49f27301e8dffdfec5ac355adb4557892707cdb0 (patch)
tree62684ac30a9d534855d3d6ce456d6826862eaf88 /app-emulation/docker-bench-security/docker-bench-security-1.3.3.ebuild
parentdev-python/xmltodict: remove old (diff)
downloadgentoo-49f27301e8dffdfec5ac355adb4557892707cdb0.tar.gz
gentoo-49f27301e8dffdfec5ac355adb4557892707cdb0.tar.bz2
gentoo-49f27301e8dffdfec5ac355adb4557892707cdb0.zip
app-emulation/docker-bench-security: 1.3.3 version bump
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'app-emulation/docker-bench-security/docker-bench-security-1.3.3.ebuild')
-rw-r--r--app-emulation/docker-bench-security/docker-bench-security-1.3.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-emulation/docker-bench-security/docker-bench-security-1.3.3.ebuild b/app-emulation/docker-bench-security/docker-bench-security-1.3.3.ebuild
new file mode 100644
index 000000000000..6e423e8ccc19
--- /dev/null
+++ b/app-emulation/docker-bench-security/docker-bench-security-1.3.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Test for best practices around deploying docker containers"
+HOMEPAGE="https://github.com/docker/docker-bench-security"
+SRC_URI="https://github.com/docker/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=app-emulation/docker-1.10"
+
+src_install() {
+dobin "${FILESDIR}/docker-bench-security"
+exeinto /usr/lib/${PN}
+doexe ${PN}.sh
+insinto /usr/lib/${PN}
+doins -r *lib.sh tests
+ dodoc -r benchmark_log.png CONTRIBUTING.md distros docker-compose.yml \
+ Dockerfile MAINTAINERS README.md
+}