summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2017-09-07 18:37:27 -0500
committerWilliam Hubbs <williamh@gentoo.org>2017-09-07 18:40:45 -0500
commit96085107a81f810116ae1ec0e2e267debce4c7c0 (patch)
treece43a09694867c9abe72e9e4fec3a98b7df38eb8 /app-emulation/docker-bench-security
parentsys-cluster/ceph: Clean out old versions (diff)
downloadgentoo-96085107a81f810116ae1ec0e2e267debce4c7c0.tar.gz
gentoo-96085107a81f810116ae1ec0e2e267debce4c7c0.tar.bz2
gentoo-96085107a81f810116ae1ec0e2e267debce4c7c0.zip
app-emulation/docker-bench-security: new package
This utility checks for best practices around deploying docker containers Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-emulation/docker-bench-security')
-rw-r--r--app-emulation/docker-bench-security/Manifest1
-rw-r--r--app-emulation/docker-bench-security/docker-bench-security-1.3.2.ebuild24
-rw-r--r--app-emulation/docker-bench-security/files/docker-bench-security7
-rw-r--r--app-emulation/docker-bench-security/metadata.xml12
4 files changed, 44 insertions, 0 deletions
diff --git a/app-emulation/docker-bench-security/Manifest b/app-emulation/docker-bench-security/Manifest
new file mode 100644
index 000000000000..d42cc2209a78
--- /dev/null
+++ b/app-emulation/docker-bench-security/Manifest
@@ -0,0 +1 @@
+DIST docker-bench-security-1.3.2.tar.gz 414608 SHA256 9054a7f48b6519aa618df64bf09429e6178ae4a7199164cb4db7b95f05e8df19 SHA512 7d271167584ff99fdaff15b1d303f1cedeb5888057437cc3bfae8260aff96f98d8a0173c4d4e5718bf8ee4e0ffe3ae0280f0026cf386ae32c38e8302159a2226 WHIRLPOOL 923ca76221cb1056daaa32e7d98326548fa6107a10b0325ad99687fad87df2b1fafde44c218459c2f33825f58e69ee36de62107765f0fd5f83c4e58348dcf24c
diff --git a/app-emulation/docker-bench-security/docker-bench-security-1.3.2.ebuild b/app-emulation/docker-bench-security/docker-bench-security-1.3.2.ebuild
new file mode 100644
index 000000000000..6e423e8ccc19
--- /dev/null
+++ b/app-emulation/docker-bench-security/docker-bench-security-1.3.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Test for best practices around deploying docker containers"
+HOMEPAGE="https://github.com/docker/docker-bench-security"
+SRC_URI="https://github.com/docker/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=app-emulation/docker-1.10"
+
+src_install() {
+dobin "${FILESDIR}/docker-bench-security"
+exeinto /usr/lib/${PN}
+doexe ${PN}.sh
+insinto /usr/lib/${PN}
+doins -r *lib.sh tests
+ dodoc -r benchmark_log.png CONTRIBUTING.md distros docker-compose.yml \
+ Dockerfile MAINTAINERS README.md
+}
diff --git a/app-emulation/docker-bench-security/files/docker-bench-security b/app-emulation/docker-bench-security/files/docker-bench-security
new file mode 100644
index 000000000000..3a79d1b3af4d
--- /dev/null
+++ b/app-emulation/docker-bench-security/files/docker-bench-security
@@ -0,0 +1,7 @@
+#!/bin/sh
+if [ $(id -u) -ne 0 ]; then
+ printf "%s\n" "This script must be run as root."
+ exit 1
+fi
+cd "$(dirname $0)/../lib/docker-bench-security"
+./docker-bench-security.sh
diff --git a/app-emulation/docker-bench-security/metadata.xml b/app-emulation/docker-bench-security/metadata.xml
new file mode 100644
index 000000000000..eb6d1553ceb4
--- /dev/null
+++ b/app-emulation/docker-bench-security/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <longdescription lang="en">
+ The Docker Bench for Security is a script that checks for dozens of
+ common best-practices around deploying Docker containers in production.
+ </longdescription>
+</pkgmetadata>