summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-10-01 17:33:36 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-10-01 17:33:36 -0500
commit34d6893a3b21eb48d776f7c5344cfd111c3382d3 (patch)
tree12afca7a761417b5470a91d611768566d1ef75e5 /app-emulation/docker-compose
parentdev-python/stormpath: remove version 2.4.1 (diff)
downloadgentoo-34d6893a3b21eb48d776f7c5344cfd111c3382d3.tar.gz
gentoo-34d6893a3b21eb48d776f7c5344cfd111c3382d3.tar.bz2
gentoo-34d6893a3b21eb48d776f7c5344cfd111c3382d3.zip
app-emulation/docker-compose: add version 1.8.1
Package-Manager: portage-2.3.1
Diffstat (limited to 'app-emulation/docker-compose')
-rw-r--r--app-emulation/docker-compose/Manifest1
-rw-r--r--app-emulation/docker-compose/docker-compose-1.8.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-emulation/docker-compose/Manifest b/app-emulation/docker-compose/Manifest
index 67060375e3cc..691cc37b4c3c 100644
--- a/app-emulation/docker-compose/Manifest
+++ b/app-emulation/docker-compose/Manifest
@@ -1,3 +1,4 @@
DIST docker-compose-1.8.0.tar.gz 149822 SHA256 65f46b2ac836918c68306646206612ecadbb0cf17fae1557f6d565554747a2a9 SHA512 ed7aa5b7f318cd71492ad3da672937619063b824809888928bd64275dbf89ea6152c72d96028ca796d63da7fe028dc164ae871db0fdc531c918ba9f946b0b17d WHIRLPOOL c3cbf631d01d1e96c8e29965d3e493ade80869ad43c31d6ae7129c875d4b7d0856bc6a990f5af46db761dfb1f6a615f1e4056d00b0e423be6e0a41bb6db6a564
DIST docker-compose-1.8.0_rc1.tar.gz 145401 SHA256 9c897c6dc99b0cc63b402220e5c3ff530a09c974b965d6a07f050bd7a07ef663 SHA512 75c0ec21e0edbe0086ff5229115f12469996c2a6cb569fe744b381536aa590f0001ccab7aa8f67d052613a8475e4901316c99db4116ccf1e4bc47b0b0ecb016f WHIRLPOOL 32f6f0311adb2ebaec798f1b8f654f16c397e2aa48bb0ec44c1e92c38cea8438a6fbab67b5c9b7db06a89d081675568dcb40214d3d3c9c07aff9d71e2f5f3ce8
DIST docker-compose-1.8.0_rc2.tar.gz 148581 SHA256 a2b6ff7c8cc8121567a26e158c4c3a246ab5173fc0ebdb4208923df88b4bd683 SHA512 390f65d6bca940cef8d5bedfbf20d0da4897d06a466c61d419aff6a5458d2982375f948f8a714303e8bdd62298020a506ef1430794a3d3116614f3ae14d3a6f3 WHIRLPOOL 3b874adc90704c6a02c14e8431d6ac425e0ffe3458427ff35df69ba3804aba906ac4c9ca7ef2e33a3c0ac9ff0f466d9c39c886626b37b5d4c465ccb3b3e2b686
+DIST docker-compose-1.8.1.tar.gz 151478 SHA256 1c72725a0a5cd41f56021cb51c6cba86932fb5b4155378ce883500d2644efc84 SHA512 8b33bf5b1fa3eeb5c5724e7ada8c61cf054a5cc1af68c9c9ab40955958f0f6a537f5bad8d54367dddc5ae66930d0555c83da47a48fc43f623d92fd60ad01cb62 WHIRLPOOL 5dca7ff3303833a45b0e7f462a375c58f68f4a19659e66b93bfc564701df8dfba70311151eb674a84c5a3b81703ddcc8809c6c7b89574c738ac9db96a32c93e6
diff --git a/app-emulation/docker-compose/docker-compose-1.8.1.ebuild b/app-emulation/docker-compose/docker-compose-1.8.1.ebuild
new file mode 100644
index 000000000000..f3bd7dfe82da
--- /dev/null
+++ b/app-emulation/docker-compose/docker-compose-1.8.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Multi-container orchestration for Docker"
+HOMEPAGE="https://www.docker.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+CDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/cached-property-2[${PYTHON_USEDEP}]
+ >=dev-python/dockerpty-0.4.1[${PYTHON_USEDEP}]
+ <dev-python/dockerpty-0.5[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-1.10.3[${PYTHON_USEDEP}]
+ <dev-python/docker-py-2.0[${PYTHON_USEDEP}]
+ >=dev-python/docopt-0.6.1[${PYTHON_USEDEP}]
+ <dev-python/docopt-0.7[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.5.1[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ <dev-python/pyyaml-4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.6.1[${PYTHON_USEDEP}]
+ <dev-python/requests-2.8[${PYTHON_USEDEP}]
+ >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+ <dev-python/six-2[${PYTHON_USEDEP}]
+ >=dev-python/texttable-0.8.1[${PYTHON_USEDEP}]
+ <dev-python/texttable-0.9[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+ <dev-python/websocket-client-1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '<dev-python/enum34-2[${PYTHON_USEDEP}]' 'python2_7' )
+"
+DEPEND="
+ test? (
+ ${CDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' )
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_test() {
+ ${PYTHON} -m pytest tests/unit || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp contrib/completion/bash/docker-compose ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/completion/zsh/*
+
+ distutils-r1_python_install_all
+}