summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-04-03 09:49:01 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-04-03 09:49:01 -0500
commit7176578529af463023471c3805b76cd5a6f3ba4d (patch)
tree2ea0186dbff1376fbfb8dc54ec2c90a99aca809f /app-emulation/docker-compose
parentdev-python/docker-py: remove version 1.5.0 (diff)
downloadgentoo-7176578529af463023471c3805b76cd5a6f3ba4d.tar.gz
gentoo-7176578529af463023471c3805b76cd5a6f3ba4d.tar.bz2
gentoo-7176578529af463023471c3805b76cd5a6f3ba4d.zip
app-emulation/docker-compose: add version 1.7.0_rc1
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-emulation/docker-compose')
-rw-r--r--app-emulation/docker-compose/Manifest1
-rw-r--r--app-emulation/docker-compose/docker-compose-1.7.0_rc1.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-emulation/docker-compose/Manifest b/app-emulation/docker-compose/Manifest
index 342b7029ebb0..a5dc6364ea65 100644
--- a/app-emulation/docker-compose/Manifest
+++ b/app-emulation/docker-compose/Manifest
@@ -1,3 +1,4 @@
DIST docker-compose-1.5.1.tar.gz 104331 SHA256 df5e885fd758a2b5983574d6718b5a07f92c7166c5706dc6ff88687d27bfaf55 SHA512 be6678c27b73516e14bf80255e52bde72517bd65a91f1be2393a15f0f0b87ff9ddd785e22016a9a5e1a68d5e6b9be395a96d60b7bc862f24647adf81752b9baa WHIRLPOOL 0b1312cb0d99a7cf02d8a88a7b00f3105f497c1cfa0ac3b32b369cd3984f2b1eaa8ea2c9e2e5a70ada3a371fb8a774245b75eaf5a7665170398df5f703793311
DIST docker-compose-1.5.2.tar.gz 106583 SHA256 79aa7e2e6ef9ab1936f8777476ffd4bb329875ec3d3664d239896d2f2a3c4f4f SHA512 be671503bbb91fdb5fdf9ff593f28d290d1c65738d055629d8252cf4c4eea7f5931a1e1d6d7a0b27640166671ecb095b413cb694b768437be3ec207e059f4ccc WHIRLPOOL bb12df93739329b9577db41a317a22976dc97ca1d1d3dd72e2ff4b8c245caf106f1aab466d42ffa7b9e6a7bf6f628f8977d2700460591051dade074535f0175e
DIST docker-compose-1.6.2.tar.gz 128730 SHA256 264e2cbdd3fa314ba75f2681d10b0cff8d989a62979c1ba42d15a6d4c4002482 SHA512 7254a7e88b9030eeac87c1c6abfeea12e978519cc4e0236e37537c3143198d448e504107b1599b355a3c75e03e0acbd6fe552d0ff482cd3e91772d759a85544a WHIRLPOOL 3755ef9c189bd08f5bb810bf527041393ab788dcd302e6f1553989de73375ba34e062d2b21c10b144132ce9eb3997310b683b1b5b46aaf992fedfaa652deb6b2
+DIST docker-compose-1.7.0_rc1.tar.gz 140008 SHA256 ae4777e14fa64d2016f2dcbca34b39e2976150ca324241b68b5a82f753ee08ef SHA512 3405f59fae198633f7bb8ac8d9c94294d221751a551a91a96ac131f520cabec068a5aa4ba502c5e8eb9a3907e6f8527de2e39a12a66980ad978cb5b7d96cac06 WHIRLPOOL 82e2226a0fdf06b25da3da27ddf53739c0e583e290ce94747298c75aee5f8f37b353d1bcf1fe7e57e20daa53637ac36d9fb1787e8243176c7108f38e5a697b42
diff --git a/app-emulation/docker-compose/docker-compose-1.7.0_rc1.ebuild b/app-emulation/docker-compose/docker-compose-1.7.0_rc1.ebuild
new file mode 100644
index 000000000000..6434132257ef
--- /dev/null
+++ b/app-emulation/docker-compose/docker-compose-1.7.0_rc1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit bash-completion-r1 distutils-r1 vcs-snapshot
+
+MY_PV=${PV//_/}
+
+DESCRIPTION="Multi-container orchestration for Docker"
+HOMEPAGE="https://www.docker.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PN}-${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+CDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/cached-property-2[${PYTHON_USEDEP}]
+ >=dev-python/dockerpty-0.4.1[${PYTHON_USEDEP}]
+ <dev-python/dockerpty-0.5[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-1.7.2[${PYTHON_USEDEP}]
+ <dev-python/docker-py-2[${PYTHON_USEDEP}]
+ >=dev-python/docopt-0.6.1[${PYTHON_USEDEP}]
+ <dev-python/docopt-0.7[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.5.1[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ <dev-python/pyyaml-4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.6.1[${PYTHON_USEDEP}]
+ <dev-python/requests-2.8[${PYTHON_USEDEP}]
+ >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+ <dev-python/six-2[${PYTHON_USEDEP}]
+ >=dev-python/texttable-0.8.1[${PYTHON_USEDEP}]
+ <dev-python/texttable-0.9[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+ <dev-python/websocket-client-1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '<dev-python/enum34-2[${PYTHON_USEDEP}]' 'python2_7' )
+"
+DEPEND="
+ test? (
+ ${CDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' )
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_test() {
+ ${PYTHON} -m pytest tests/unit || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp contrib/completion/bash/docker-compose ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/completion/zsh/*
+
+ distutils-r1_python_install_all
+}