summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2016-03-25 13:13:37 -0700
committerZac Medico <zmedico@gentoo.org>2016-03-25 13:13:43 -0700
commite5b263cef669c713e9868030cab9035a53f45f31 (patch)
treeb28f3d1d1b757c75599d814664b5ce0e20bda820 /app-emulation/docker-machine/docker-machine-0.6.0.ebuild
parentx11-drivers/xf86-video-ati: Add snapshot (diff)
downloadgentoo-e5b263cef669c713e9868030cab9035a53f45f31.tar.gz
gentoo-e5b263cef669c713e9868030cab9035a53f45f31.tar.bz2
gentoo-e5b263cef669c713e9868030cab9035a53f45f31.zip
app-emulation/docker-machine: version bump to 0.6.0
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-emulation/docker-machine/docker-machine-0.6.0.ebuild')
-rw-r--r--app-emulation/docker-machine/docker-machine-0.6.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-emulation/docker-machine/docker-machine-0.6.0.ebuild b/app-emulation/docker-machine/docker-machine-0.6.0.ebuild
new file mode 100644
index 000000000000..106b440e21f0
--- /dev/null
+++ b/app-emulation/docker-machine/docker-machine-0.6.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGO_PN=github.com/docker/machine/...
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="v${PV}"
+ SRC_URI="https://${EGO_PN%/*}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Machine management for a container-centric world"
+HOMEPAGE="https://docs.docker.com/machine/ "
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+RESTRICT="test"
+DEPEND=">=dev-lang/go-1.5:="
+RDEPEND=""
+S=${WORKDIR}/${P}/src/${EGO_PN%/*}
+
+src_prepare() {
+ # don't pre-strip binaries
+ sed -e 's|\(GO_LDFLAGS := $(GO_LDFLAGS) -w\) -s|\1|' -i mk/main.mk ||die
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" emake build || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc CHANGELOG.md CONTRIBUTING.md README.md ROADMAP.md
+}