summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-03-20 15:45:22 -0700
committerZac Medico <zmedico@gentoo.org>2019-03-20 15:45:40 -0700
commit496d7b5ac1e6a32b7cdf799aa2ba2c2b3dcba575 (patch)
tree25b9141b19739df0466d9e3c9f63bd85a2bdb243 /app-emulation/docker-registry
parentapp-emulation/wine-staging: Sync with ::wine (diff)
downloadgentoo-496d7b5ac1e6a32b7cdf799aa2ba2c2b3dcba575.tar.gz
gentoo-496d7b5ac1e6a32b7cdf799aa2ba2c2b3dcba575.tar.bz2
gentoo-496d7b5ac1e6a32b7cdf799aa2ba2c2b3dcba575.zip
app-emulation/docker-registry: filter GOCACHE vars (bug 681072)
Reported-by: Toralf Förster <toralf@gentoo.org> Closes: https://bugs.gentoo.org/681072 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-emulation/docker-registry')
-rw-r--r--app-emulation/docker-registry/docker-registry-2.6.2-r1.ebuild3
-rw-r--r--app-emulation/docker-registry/docker-registry-2.7.0-r1.ebuild3
-rw-r--r--app-emulation/docker-registry/docker-registry-2.7.0.ebuild3
-rw-r--r--app-emulation/docker-registry/docker-registry-2.7.1.ebuild1
4 files changed, 7 insertions, 3 deletions
diff --git a/app-emulation/docker-registry/docker-registry-2.6.2-r1.ebuild b/app-emulation/docker-registry/docker-registry-2.6.2-r1.ebuild
index 6ea2a86bd59b..863b9ac50826 100644
--- a/app-emulation/docker-registry/docker-registry-2.6.2-r1.ebuild
+++ b/app-emulation/docker-registry/docker-registry-2.6.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -23,6 +23,7 @@ pkg_setup() {
}
src_compile() {
+ export -n GOCACHE XDG_CACHE_HOME #681072
GOPATH="${S}" \
go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}/..." || die
}
diff --git a/app-emulation/docker-registry/docker-registry-2.7.0-r1.ebuild b/app-emulation/docker-registry/docker-registry-2.7.0-r1.ebuild
index 7f36e363292f..c117f1e13143 100644
--- a/app-emulation/docker-registry/docker-registry-2.7.0-r1.ebuild
+++ b/app-emulation/docker-registry/docker-registry-2.7.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -28,6 +28,7 @@ src_prepare() {
}
src_compile() {
+ export -n GOCACHE XDG_CACHE_HOME #681072
GOPATH="${S}" \
go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}/..." || die
}
diff --git a/app-emulation/docker-registry/docker-registry-2.7.0.ebuild b/app-emulation/docker-registry/docker-registry-2.7.0.ebuild
index 152ac01305b7..90b39c280c9e 100644
--- a/app-emulation/docker-registry/docker-registry-2.7.0.ebuild
+++ b/app-emulation/docker-registry/docker-registry-2.7.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -21,6 +21,7 @@ pkg_setup() {
}
src_compile() {
+ export -n GOCACHE XDG_CACHE_HOME #681072
GOPATH="${S}" \
go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}/..." || die
}
diff --git a/app-emulation/docker-registry/docker-registry-2.7.1.ebuild b/app-emulation/docker-registry/docker-registry-2.7.1.ebuild
index 3ab8dea64489..57b97ad055d0 100644
--- a/app-emulation/docker-registry/docker-registry-2.7.1.ebuild
+++ b/app-emulation/docker-registry/docker-registry-2.7.1.ebuild
@@ -31,6 +31,7 @@ src_prepare() {
}
src_compile() {
+ export -n GOCACHE XDG_CACHE_HOME #681072
GOPATH="${S}" GO_BUILD_FLAGS="-v" emake -C src/${EGO_PN} binaries
}