summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-06-26 05:50:31 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-06-26 06:10:09 -0400
commit56d9f95e7c64ac526c828494c3c57062eefe20fe (patch)
treee336366786cddbca3499f3d6629a16b332c775aa /app-emulation/dxvk
parentapp-emulation/wine-proton: pass -mno-avx for mingw cross (diff)
downloadgentoo-56d9f95e7c64ac526c828494c3c57062eefe20fe.tar.gz
gentoo-56d9f95e7c64ac526c828494c3c57062eefe20fe.tar.bz2
gentoo-56d9f95e7c64ac526c828494c3c57062eefe20fe.zip
app-emulation/dxvk: update -mno-avx comment to match wine
Unsure for the status of issues with dxvk, the old Tk-Glitch issue (who were building this with -march=native) is 404 given repos changed around and unsure what the reproducer is. But given seemingly bad code is being generated for recent Wine I think this is unsafe enough that should keep it for now. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation/dxvk')
-rw-r--r--app-emulation/dxvk/dxvk-1.10.3.ebuild6
-rw-r--r--app-emulation/dxvk/dxvk-2.0.ebuild6
-rw-r--r--app-emulation/dxvk/dxvk-2.1.ebuild7
-rw-r--r--app-emulation/dxvk/dxvk-2.2.ebuild7
-rw-r--r--app-emulation/dxvk/dxvk-9999.ebuild7
5 files changed, 20 insertions, 13 deletions
diff --git a/app-emulation/dxvk/dxvk-1.10.3.ebuild b/app-emulation/dxvk/dxvk-1.10.3.ebuild
index e9f3f4344b63..c11db845a715 100644
--- a/app-emulation/dxvk/dxvk-1.10.3.ebuild
+++ b/app-emulation/dxvk/dxvk-1.10.3.ebuild
@@ -66,8 +66,10 @@ src_prepare() {
src_configure() {
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
- # AVX has a history of causing issues with this package, disable for safety
- # https://github.com/Tk-Glitch/PKGBUILDS/issues/515
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
append-flags -mno-avx
if [[ ${CHOST} != *-mingw* ]]; then
diff --git a/app-emulation/dxvk/dxvk-2.0.ebuild b/app-emulation/dxvk/dxvk-2.0.ebuild
index f2b240b7f42a..51375fb11c10 100644
--- a/app-emulation/dxvk/dxvk-2.0.ebuild
+++ b/app-emulation/dxvk/dxvk-2.0.ebuild
@@ -82,8 +82,10 @@ src_prepare() {
src_configure() {
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
- # AVX has a history of causing issues with this package, disable for safety
- # https://github.com/Tk-Glitch/PKGBUILDS/issues/515
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
append-flags -mno-avx
if [[ ${CHOST} != *-mingw* ]]; then
diff --git a/app-emulation/dxvk/dxvk-2.1.ebuild b/app-emulation/dxvk/dxvk-2.1.ebuild
index af2054a54097..28608a67906c 100644
--- a/app-emulation/dxvk/dxvk-2.1.ebuild
+++ b/app-emulation/dxvk/dxvk-2.1.ebuild
@@ -90,9 +90,10 @@ src_prepare() {
src_configure() {
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
- # AVX has a history of causing issues with this package, disable for safety
- # https://bugs.winehq.org/show_bug.cgi?id=43516
- # https://bugs.winehq.org/show_bug.cgi?id=45289
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
append-flags -mno-avx
if [[ ${CHOST} != *-mingw* ]]; then
diff --git a/app-emulation/dxvk/dxvk-2.2.ebuild b/app-emulation/dxvk/dxvk-2.2.ebuild
index 377428505711..b2ad8ecef4f0 100644
--- a/app-emulation/dxvk/dxvk-2.2.ebuild
+++ b/app-emulation/dxvk/dxvk-2.2.ebuild
@@ -86,9 +86,10 @@ src_prepare() {
src_configure() {
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
- # AVX has a history of causing issues with this package, disable for safety
- # https://bugs.winehq.org/show_bug.cgi?id=43516
- # https://bugs.winehq.org/show_bug.cgi?id=45289
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
append-flags -mno-avx
if [[ ${CHOST} != *-mingw* ]]; then
diff --git a/app-emulation/dxvk/dxvk-9999.ebuild b/app-emulation/dxvk/dxvk-9999.ebuild
index b2469528ebc8..12656f42a335 100644
--- a/app-emulation/dxvk/dxvk-9999.ebuild
+++ b/app-emulation/dxvk/dxvk-9999.ebuild
@@ -86,9 +86,10 @@ src_prepare() {
src_configure() {
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
- # AVX has a history of causing issues with this package, disable for safety
- # https://bugs.winehq.org/show_bug.cgi?id=43516
- # https://bugs.winehq.org/show_bug.cgi?id=45289
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
append-flags -mno-avx
if [[ ${CHOST} != *-mingw* ]]; then