summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-10-17 15:38:48 +0200
committerManuel Rüger <mrueg@gentoo.org>2019-10-17 15:38:48 +0200
commit2b70d56f25496e5d88afadeef6c498da2685c8cc (patch)
treebbc3be9361577e021292c4c72e9f1a633c7ff6db /app-emulation/kompose
parentwww-apps/grafana-bin: Version bump to 6.4.3 (diff)
downloadgentoo-2b70d56f25496e5d88afadeef6c498da2685c8cc.tar.gz
gentoo-2b70d56f25496e5d88afadeef6c498da2685c8cc.tar.bz2
gentoo-2b70d56f25496e5d88afadeef6c498da2685c8cc.zip
app-emulation/kompose: Version bump to 1.19.0
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'app-emulation/kompose')
-rw-r--r--app-emulation/kompose/Manifest1
-rw-r--r--app-emulation/kompose/kompose-1.19.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-emulation/kompose/Manifest b/app-emulation/kompose/Manifest
index 6610b830cd6e..4975b9db5488 100644
--- a/app-emulation/kompose/Manifest
+++ b/app-emulation/kompose/Manifest
@@ -1 +1,2 @@
DIST kompose-1.16.0.tar.gz 5241785 BLAKE2B 9958b200827b70c94a499981880cc7a5d8137354205d96657d854aefebbd877e332ac3047f59e13b62dd6b9a9235d1ed83bb8b8de973d59f81906b3f376176a0 SHA512 267601ba51f5cfcbb95b9fbf52bbb99f9c810de8edb301b635a50936d7a714dc8410352ff3a4aa8819de1659a45cbb42caf5e552023cfa594a0eb8e99db57522
+DIST kompose-1.19.0.tar.gz 5314491 BLAKE2B c03f7ece6dc91979a147bb1689525318b7c31b22242e6fbf5387469d3196dfc569178235b5a52ccdd9647ceb626be313017484451f149e375edf3b48da063328 SHA512 571c5f23a19ba1f7a403e2369d74a5f6ba051c5e9c27b79bf5ab05f8dfc9abd523862dad7da3cd0d503e4de2e76666cd1eea8d8921b0bbe79db81f11a23fbe64
diff --git a/app-emulation/kompose/kompose-1.19.0.ebuild b/app-emulation/kompose/kompose-1.19.0.ebuild
new file mode 100644
index 000000000000..6262daaf7558
--- /dev/null
+++ b/app-emulation/kompose/kompose-1.19.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/kubernetes/kompose"
+EGIT_COMMIT="v${PV}"
+GIT_COMMIT="f63a961ca7972cb243507755c69cd066aa792289"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Tool to move from docker-compose to Kubernetes"
+HOMEPAGE="https://github.com/kubernetes/kompose https://kompose.io"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="hardened"
+
+RESTRICT="test"
+
+src_compile() {
+ export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')"
+ GOPATH="${S}" go build -v -ldflags="-X github.com/kubernetes/kompose/cmd.GITCOMMIT=${GIT_COMMIT}" -o bin/kompose src/${EGO_PN}/main.go || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r src/${EGO_PN}/{docs,{README,RELEASE,ROADMAP,CHANGELOG,CONTRIBUTING}.md}
+}