summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-11-05 20:59:46 +0100
committerPacho Ramos <pacho@gentoo.org>2015-11-05 21:00:39 +0100
commit02276cbb920a4a58bf94ddb46575cb2a334c3c39 (patch)
treefe6142a65dd2fe10091c43fdd2a7b356c5fa8ecf /app-emulation/kvm-kmod/kvm-kmod-3.10.1.ebuild
parentdev-lang/php: don't depend on versions of sys-libs/db that won't be detected. (diff)
downloadgentoo-02276cbb920a4a58bf94ddb46575cb2a334c3c39.tar.gz
gentoo-02276cbb920a4a58bf94ddb46575cb2a334c3c39.tar.bz2
gentoo-02276cbb920a4a58bf94ddb46575cb2a334c3c39.zip
Remove hard masked package
Diffstat (limited to 'app-emulation/kvm-kmod/kvm-kmod-3.10.1.ebuild')
-rw-r--r--app-emulation/kvm-kmod/kvm-kmod-3.10.1.ebuild68
1 files changed, 0 insertions, 68 deletions
diff --git a/app-emulation/kvm-kmod/kvm-kmod-3.10.1.ebuild b/app-emulation/kvm-kmod/kvm-kmod-3.10.1.ebuild
deleted file mode 100644
index bdbff2e4803a..000000000000
--- a/app-emulation/kvm-kmod/kvm-kmod-3.10.1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="2"
-
-inherit eutils linux-mod
-
-SRC_URI="mirror://sourceforge/kvm/${P}.tar.bz2"
-
-DESCRIPTION="Kernel-based Virtual Machine kernel modules"
-HOMEPAGE="http://www.linux-kvm.org"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
-IUSE=""
-RESTRICT="test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- linux-mod_pkg_setup
-
- linux_config_exists || die "Your kernel sources are unconfigured"
-
- if ! linux_chkconfig_present KVM; then
- eerror "KVM now needs CONFIG_KVM built into your kernel, even"
- eerror "if you're using the external modules from this package."
- eerror "Please enable KVM support in your kernel, found at:"
- eerror
- eerror " Virtualization"
- eerror " Kernel-based Virtual Machine (KVM) support"
- eerror
- die "KVM support not detected!"
- fi
- BUILD_TARGETS="all"
- MODULE_NAMES="kvm(kernel/arch/x86/kvm/:${S}:${S}/x86)"
- MODULE_NAMES="${MODULE_NAMES} kvm-intel(kernel/arch/x86/kvm/:${S}:${S}/x86)"
- MODULE_NAMES="${MODULE_NAMES} kvm-amd(kernel/arch/x86/kvm/:${S}:${S}/x86)"
-}
-
-src_configure() {
- local conf_opts
-
- conf_opts="--kerneldir=$KV_DIR"
-
- if has_multilib_profile && [[ "${DEFAULT_ABI}" == "x86" ]] ; then
- conf_opts="$conf_opts --arch=x86"
- fi
-
- ./configure ${conf_opts} || die "configure failed"
-}
-
-src_compile() {
- linux-mod_src_compile
-}
-
-src_install() {
- linux-mod_src_install
-}
-
-pkg_preinst() {
- find /lib/modules/${KV_FULL} -name 'kvm*.ko' -type f -delete
-
- linux-mod_pkg_preinst
-}