summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emulation/kvm-kmod/kvm-kmod-3.10.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emulation/kvm-kmod/kvm-kmod-3.10.1.ebuild')
-rw-r--r--app-emulation/kvm-kmod/kvm-kmod-3.10.1.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/app-emulation/kvm-kmod/kvm-kmod-3.10.1.ebuild b/app-emulation/kvm-kmod/kvm-kmod-3.10.1.ebuild
new file mode 100644
index 000000000000..bdbff2e4803a
--- /dev/null
+++ b/app-emulation/kvm-kmod/kvm-kmod-3.10.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils linux-mod
+
+SRC_URI="mirror://sourceforge/kvm/${P}.tar.bz2"
+
+DESCRIPTION="Kernel-based Virtual Machine kernel modules"
+HOMEPAGE="http://www.linux-kvm.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ linux_config_exists || die "Your kernel sources are unconfigured"
+
+ if ! linux_chkconfig_present KVM; then
+ eerror "KVM now needs CONFIG_KVM built into your kernel, even"
+ eerror "if you're using the external modules from this package."
+ eerror "Please enable KVM support in your kernel, found at:"
+ eerror
+ eerror " Virtualization"
+ eerror " Kernel-based Virtual Machine (KVM) support"
+ eerror
+ die "KVM support not detected!"
+ fi
+ BUILD_TARGETS="all"
+ MODULE_NAMES="kvm(kernel/arch/x86/kvm/:${S}:${S}/x86)"
+ MODULE_NAMES="${MODULE_NAMES} kvm-intel(kernel/arch/x86/kvm/:${S}:${S}/x86)"
+ MODULE_NAMES="${MODULE_NAMES} kvm-amd(kernel/arch/x86/kvm/:${S}:${S}/x86)"
+}
+
+src_configure() {
+ local conf_opts
+
+ conf_opts="--kerneldir=$KV_DIR"
+
+ if has_multilib_profile && [[ "${DEFAULT_ABI}" == "x86" ]] ; then
+ conf_opts="$conf_opts --arch=x86"
+ fi
+
+ ./configure ${conf_opts} || die "configure failed"
+}
+
+src_compile() {
+ linux-mod_src_compile
+}
+
+src_install() {
+ linux-mod_src_install
+}
+
+pkg_preinst() {
+ find /lib/modules/${KV_FULL} -name 'kvm*.ko' -type f -delete
+
+ linux-mod_pkg_preinst
+}