summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-02-21 23:37:29 +0100
committerDavid Seifert <soap@gentoo.org>2016-02-21 23:37:46 +0100
commit53e73ee4e31a603d3b067a7090ef73f683c70626 (patch)
tree051d103baac2d770bdbe9759cc2565681a4f5aa4 /app-emulation/libcacard/libcacard-0.1.2.ebuild
parentapp-admin/consul: revison bump ebuilds for bug #575272 (diff)
downloadgentoo-53e73ee4e31a603d3b067a7090ef73f683c70626.tar.gz
gentoo-53e73ee4e31a603d3b067a7090ef73f683c70626.tar.bz2
gentoo-53e73ee4e31a603d3b067a7090ef73f683c70626.zip
app-emulation/libcacard: Detect libpthread flags properly
Gentoo-Bug: 494450 * EAPI=6 * Unconditionally delete .la files, due to provided pkg-config file Package-Manager: portage-2.2.27
Diffstat (limited to 'app-emulation/libcacard/libcacard-0.1.2.ebuild')
-rw-r--r--app-emulation/libcacard/libcacard-0.1.2.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/app-emulation/libcacard/libcacard-0.1.2.ebuild b/app-emulation/libcacard/libcacard-0.1.2.ebuild
index 78a3c4b1a49b..065ba5d801b2 100644
--- a/app-emulation/libcacard/libcacard-0.1.2.ebuild
+++ b/app-emulation/libcacard/libcacard-0.1.2.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
+
+inherit autotools eutils
DESCRIPTION="Library for emulating CAC cards"
HOMEPAGE="http://spice-space.org/"
@@ -17,6 +19,14 @@ RDEPEND=">=dev-libs/nss-3.13
>=sys-apps/pcsc-lite-1.8"
DEPEND="${RDEPEND}
virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}/${P}-underlinking.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
src_configure() {
# --enable-passthru works only on W$
@@ -26,5 +36,5 @@ src_configure() {
src_install() {
default
- use static-libs || rm "${D}"/usr/lib*/*.la
+ prune_libtool_files --all
}