summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2015-12-27 14:02:54 +0100
committerMatthias Maier <tamiko@gentoo.org>2015-12-27 14:06:55 +0100
commit3fae8409c95850d27c0c7a9344e400c653730540 (patch)
treec7bb020a9b5d503ce13a8858905e7638bfa0fb4c /app-emulation/libvirt-glib
parentVersion bump (CVE-2015-8669) - fixes bug 569800. (diff)
downloadgentoo-3fae8409c95850d27c0c7a9344e400c653730540.tar.gz
gentoo-3fae8409c95850d27c0c7a9344e400c653730540.tar.bz2
gentoo-3fae8409c95850d27c0c7a9344e400c653730540.zip
app-emulation/libvirt-glib: version bump to 0.2.3
Thanks to Dessa for pointing this out. Package-Manager: portage-2.2.26
Diffstat (limited to 'app-emulation/libvirt-glib')
-rw-r--r--app-emulation/libvirt-glib/Manifest1
-rw-r--r--app-emulation/libvirt-glib/libvirt-glib-0.2.3.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/app-emulation/libvirt-glib/Manifest b/app-emulation/libvirt-glib/Manifest
index 42e9da51bbe7..155d4003103a 100644
--- a/app-emulation/libvirt-glib/Manifest
+++ b/app-emulation/libvirt-glib/Manifest
@@ -1 +1,2 @@
DIST libvirt-glib-0.2.2.tar.gz 853052 SHA256 d7be16025231c91ccae43838b7cdb1d55d181856a2a50b0f7b1c5078ad202d9d SHA512 77adcf74dd057b8c5e3c21e1fbe0a99eedbe0005d0247c0173bce69e4e6209dbffe18c7a2f0de9a4c279f138ab5bcc360c14cc2335d0b2b55f22b5819c3e5b70 WHIRLPOOL 628d76cf20fe0b707a56688ad4f17c2c95b12b89fe89f4628e42cee2e8c5855aeac0e06ad45fe71fb63ae935b1ff7a17ee69f294b8358653f7cbcd03aea59876
+DIST libvirt-glib-0.2.3.tar.gz 876258 SHA256 c3b11aa34584b3416148b36bb005505e461830c73c9fd2f40143cca3309250dd SHA512 007e642724658e7f2d4ad10094e70a93186196467140662d5e71644ae8efac25a7f60dcf51b55b60d056d3079ecf0798428e077cb6110292ce5f2a474db9e369 WHIRLPOOL 594ab70f4647e053d9540e857aeba7853491200d825eed713a1025afe5eabbe2f3c698d30b00e0da1735f2fc8465212eae2a965fb93a68099df5d11ce494a0d2
diff --git a/app-emulation/libvirt-glib/libvirt-glib-0.2.3.ebuild b/app-emulation/libvirt-glib/libvirt-glib-0.2.3.ebuild
new file mode 100644
index 000000000000..a5ccb744bdff
--- /dev/null
+++ b/app-emulation/libvirt-glib/libvirt-glib-0.2.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-single-r1 vala
+
+DESCRIPTION="GLib and GObject mappings for libvirt"
+HOMEPAGE="http://libvirt.org/git/?p=libvirt-glib.git"
+SRC_URI="ftp://libvirt.org/libvirt/glib/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection python +vala"
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ vala? ( introspection )
+"
+
+# https://bugzilla.redhat.com/show_bug.cgi?id=1093633
+RESTRICT="test"
+
+RDEPEND="
+ dev-libs/libxml2:2
+ >=app-emulation/libvirt-1.2.6:=
+ >=dev-libs/glib-2.38.0:2
+ introspection? ( >=dev-libs/gobject-introspection-0.10.8:= )
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-test-coverage \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ $(use_with python)
+}