summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2019-12-31 15:27:31 -0600
committerMatthias Maier <tamiko@gentoo.org>2019-12-31 16:01:27 -0600
commite62cbac3cd0893797cde1b96e40da1aecd7d9b61 (patch)
treea4f073e478c2a4df37c380807c35dac68f70c34f /app-emulation/libvirt-glib
parentdev-python/libvirt-python: version bump to 5.10.0 (diff)
downloadgentoo-e62cbac3cd0893797cde1b96e40da1aecd7d9b61.tar.gz
gentoo-e62cbac3cd0893797cde1b96e40da1aecd7d9b61.tar.bz2
gentoo-e62cbac3cd0893797cde1b96e40da1aecd7d9b61.zip
app-emulation/libvirt-glib: version bump to 3.0.0
Closes: https://bugs.gentoo.org/703454 Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'app-emulation/libvirt-glib')
-rw-r--r--app-emulation/libvirt-glib/Manifest1
-rw-r--r--app-emulation/libvirt-glib/libvirt-glib-3.0.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-emulation/libvirt-glib/Manifest b/app-emulation/libvirt-glib/Manifest
index 09832689389c..7978802829e3 100644
--- a/app-emulation/libvirt-glib/Manifest
+++ b/app-emulation/libvirt-glib/Manifest
@@ -1,2 +1,3 @@
DIST libvirt-glib-1.0.0.tar.gz 860450 BLAKE2B 417a3bd0df41787fbec456f301af744a04649db02192ef9c80bf42214a112a050a9f054c81549a114e7a1236c86e0066e8002f0c7f09317abb672fe5f6a76789 SHA512 72f53a90d3e40aa93d4afe5b29f631afe859532fbdb4e27086da3bd4cdaf0fb25fc808a82a1994b7c2648a1e864876ce95de28acb3b4876dac47b0f4d1c97ba5
DIST libvirt-glib-2.0.0.tar.gz 868946 BLAKE2B 1ff4695b25766d6caa603826dcc63e64aa3ce022e6623eb31017fb67a490baeb546a9bc67e16fc16c7b86040db971748b1ef4303a21b5dec098cf732f77c92ec SHA512 6ead4c37c314eb5670c5aa282ce039a0182a71a20b349a5d9c78367381eb674fad0f2ca0f2e20e1e89ff7df2ac9f1640f20fdfa63d599d8a2538fb4c0fba4c3f
+DIST libvirt-glib-3.0.0.tar.gz 899180 BLAKE2B ef10b3d9bad48e49dd1898733aacb2f51f1826330eda9c63a7f8df5f11c96812f8cc7fe6a867961efa85a433f45c934d75cf605eb523ec723459da4646335b1a SHA512 b9e7d782c25b5c3a9b2829f1be8162352438ab3505510a1ca7dd64d741eaab158dc9206fdd4b0e3e27b0c049e4bcfc47db0c9a7fa1a84888864e23d3c35c079e
diff --git a/app-emulation/libvirt-glib/libvirt-glib-3.0.0.ebuild b/app-emulation/libvirt-glib/libvirt-glib-3.0.0.ebuild
new file mode 100644
index 000000000000..887675b3d8bc
--- /dev/null
+++ b/app-emulation/libvirt-glib/libvirt-glib-3.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 vala
+
+DESCRIPTION="GLib and GObject mappings for libvirt"
+HOMEPAGE="http://libvirt.org/git/?p=libvirt-glib.git"
+SRC_URI="ftp://libvirt.org/libvirt/glib/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="+introspection nls +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ dev-libs/libxml2:2
+ >=app-emulation/libvirt-1.2.6:=
+ >=dev-libs/glib-2.38.0:2
+ introspection? ( >=dev-libs/gobject-introspection-1.36.0:= )"
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )"
+
+src_prepare() {
+ gnome2_src_prepare
+ use vala && vala_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-test-coverage \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable nls) \
+ $(use_enable vala)
+}