summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-16 00:43:57 +0100
committerSam James <sam@gentoo.org>2021-10-16 00:48:57 +0100
commit46551403d78089179da19f060682e9d7bffe07e7 (patch)
tree571bf5ddcea7a0d807df45546c26cd83caa69333 /app-emulation/libvirt/libvirt-9999.ebuild
parentapp-emulation/libvirt: skip syntax checks (diff)
downloadgentoo-46551403d78089179da19f060682e9d7bffe07e7.tar.gz
gentoo-46551403d78089179da19f060682e9d7bffe07e7.tar.bz2
gentoo-46551403d78089179da19f060682e9d7bffe07e7.zip
app-emulation/libvirt: increase test timeout for slower arches
Bug: https://bugs.gentoo.org/802876 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emulation/libvirt/libvirt-9999.ebuild')
-rw-r--r--app-emulation/libvirt/libvirt-9999.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/app-emulation/libvirt/libvirt-9999.ebuild b/app-emulation/libvirt/libvirt-9999.ebuild
index 7eebe2d3d822..885c9c37f2d2 100644
--- a/app-emulation/libvirt/libvirt-9999.ebuild
+++ b/app-emulation/libvirt/libvirt-9999.ebuild
@@ -288,7 +288,9 @@ src_test() {
export VIR_TEST_DEBUG=1
# Don't run the syntax check tests, they're fragile and not relevant
# to us downstream anyway.
- meson_src_test --no-suite syntax-check
+ # We also crank up the timeout (as Fedora does) just to preempt failures
+ # on slower arches.
+ meson_src_test --no-suite syntax-check --timeout-multiplier 10
}
src_install() {