summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Privoznik <michal.privoznik@gmail.com>2023-06-03 19:23:37 +0200
committerSam James <sam@gentoo.org>2023-06-04 02:05:57 +0100
commit712bfd92b0a700215c56b0a5b26ab4006530a625 (patch)
tree8c4b6f8ee632655ae29b729ac17c3371ca3648e3 /app-emulation/libvirt/libvirt-9999.ebuild
parentapp-emulation/qemu: update live ebuild (diff)
downloadgentoo-712bfd92b0a700215c56b0a5b26ab4006530a625.tar.gz
gentoo-712bfd92b0a700215c56b0a5b26ab4006530a625.tar.bz2
gentoo-712bfd92b0a700215c56b0a5b26ab4006530a625.zip
app-emulation/libvirt: Fix IP_NF_TARGET_MASQUERADE check
As of kernel commit v5.2-rc1~133^2~174^2~6 the IP_NF_TARGET_MASQUERADE is just an alias for NETFILTER_XT_TARGET_MASQUERADE: config IP_NF_TARGET_MASQUERADE tristate "MASQUERADE target support" select NETFILTER_XT_TARGET_MASQUERADE help This is a backwards-compat option for the user's convenience (e.g. when running oldconfig). It selects NETFILTER_XT_TARGET_MASQUERADE. Fine tune our kernel config checks, though this can be changed once kernels older than 5.2.0 leave the tree. Closes: https://bugs.gentoo.org/907728 Signed-off-by: Michal Privoznik <michal.privoznik@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31292 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emulation/libvirt/libvirt-9999.ebuild')
-rw-r--r--app-emulation/libvirt/libvirt-9999.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/app-emulation/libvirt/libvirt-9999.ebuild b/app-emulation/libvirt/libvirt-9999.ebuild
index 3d66a605794d..b2849810143e 100644
--- a/app-emulation/libvirt/libvirt-9999.ebuild
+++ b/app-emulation/libvirt/libvirt-9999.ebuild
@@ -198,10 +198,21 @@ pkg_setup() {
~IP_NF_FILTER
~IP_NF_MANGLE
~IP_NF_NAT
- ~IP_NF_TARGET_MASQUERADE
~IP6_NF_FILTER
~IP6_NF_MANGLE
~IP6_NF_NAT"
+
+ # This was renamed in kernel commit v5.2-rc1~133^2~174^2~6
+ if use virt-network ; then
+ if kernel_is -lt 5 2 ; then
+ CONFIG_CHECK+="
+ ~IP_NF_TARGET_MASQUERADE"
+ else
+ CONFIG_CHECK+="
+ ~NETFILTER_XT_TARGET_MASQUERADE"
+ fi
+ fi
+
# Bandwidth Limiting Support
use virt-network && CONFIG_CHECK+="
~BRIDGE_EBT_T_NAT