summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-15 02:10:23 +0000
committerSam James <sam@gentoo.org>2022-01-15 02:10:23 +0000
commit788e72c08666ef319f9bb7615037e7e66db60b8c (patch)
tree8baa6222671e631e721b42d8a1f72939e403c38a /app-emulation/libvirt/libvirt-9999.ebuild
parentsys-fs/inotify-tools: destabilize 3.21.9.6 (diff)
downloadgentoo-788e72c08666ef319f9bb7615037e7e66db60b8c.tar.gz
gentoo-788e72c08666ef319f9bb7615037e7e66db60b8c.tar.bz2
gentoo-788e72c08666ef319f9bb7615037e7e66db60b8c.zip
Revert "app-emulation/libvirt: [QA] unconditionally install bash-completion files"
I'd missed that the Meson check is actually a bit convoluted here -- it needs adapting to always take the bashcompletiondir parameter. This reverts commit 1c4e48ea59c8e7783f02af81ee28c31ecbb628ab. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emulation/libvirt/libvirt-9999.ebuild')
-rw-r--r--app-emulation/libvirt/libvirt-9999.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/app-emulation/libvirt/libvirt-9999.ebuild b/app-emulation/libvirt/libvirt-9999.ebuild
index 0129df7341ea..fa0d16f6ac3b 100644
--- a/app-emulation/libvirt/libvirt-9999.ebuild
+++ b/app-emulation/libvirt/libvirt-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,7 +25,7 @@ HOMEPAGE="https://www.libvirt.org/ https://gitlab.com/libvirt/libvirt/"
LICENSE="LGPL-2.1"
VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/libvirt.org.asc
IUSE="
- apparmor audit +caps dtrace firewalld fuse glusterfs
+ apparmor audit bash-completion +caps dtrace firewalld fuse glusterfs
iscsi iscsi-direct +libvirtd lvm libssh lxc nfs nls numa openvz
parted pcap policykit +qemu rbd sasl selinux +udev
virtualbox +virt-network wireshark-plugins xen zfs
@@ -48,6 +48,7 @@ BDEPEND="
dev-perl/XML-XPath
dev-python/docutils
virtual/pkgconfig
+ bash-completion? ( >=app-shells/bash-completion-2.0 )
verify-sig? ( sec-keys/openpgp-keys-libvirt )"
# gettext.sh command is used by the libvirt command wrappers, and it's
@@ -278,9 +279,6 @@ src_configure() {
--localstatedir="${EPREFIX}/var"
-Drunstatedir="${EPREFIX}/run"
-Ddocdir="${EPREFIX}/usr/share/doc/${PF}"
-
- -Dbash_completion=enabled
- -Dbash_completion_dir="$(get_bashcompdir)"
)
meson_src_configure