summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <hsoft@hardcoded.net>2017-12-14 19:22:23 -0500
committerMatthias Maier <tamiko@gentoo.org>2017-12-14 19:54:49 -0600
commit10f4222c4de2373a926f90a621dff33929b4ddd4 (patch)
treee096fa44f709c8d9ffded76ab287b1b8dfe2e34c /app-emulation/lxc/files
parentnet-vpn/kvpnc: Drop localizaition to avoid blockers (diff)
downloadgentoo-10f4222c4de2373a926f90a621dff33929b4ddd4.tar.gz
gentoo-10f4222c4de2373a926f90a621dff33929b4ddd4.tar.bz2
gentoo-10f4222c4de2373a926f90a621dff33929b4ddd4.zip
app-emulation/lxc: Bump to 1.0.11
Closes: https://bugs.gentoo.org/634866 Closes: https://github.com/gentoo/gentoo/pull/6551 Package-Manager: Portage-2.3.13, Repoman-2.3.3 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'app-emulation/lxc/files')
-rw-r--r--app-emulation/lxc/files/lxc-1.0.11-bash-completion.patch27
-rw-r--r--app-emulation/lxc/files/lxc-1.0.11-major.patch64
2 files changed, 91 insertions, 0 deletions
diff --git a/app-emulation/lxc/files/lxc-1.0.11-bash-completion.patch b/app-emulation/lxc/files/lxc-1.0.11-bash-completion.patch
new file mode 100644
index 000000000000..d8d0bac55a76
--- /dev/null
+++ b/app-emulation/lxc/files/lxc-1.0.11-bash-completion.patch
@@ -0,0 +1,27 @@
+diff --git a/config/bash/lxc.in b/config/bash/lxc.in
+index 344d5cb2..f051eaae 100644
+--- a/config/bash/lxc.in
++++ b/config/bash/lxc.in
+@@ -1,4 +1,3 @@
+-_have lxc-start && {
+ _lxc_names() {
+ COMPREPLY=( $( compgen -W "$( lxc-ls )" "$cur" ) )
+ }
+@@ -100,4 +99,3 @@ _have lxc-start && {
+
+ complete -o default -F _lxc_generic_o lxc-clone
+ complete -o default -F _lxc_generic_o lxc-start-ephemeral
+-}
+diff --git a/configure.ac b/configure.ac
+index 2ea88c19..f52d772a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -429,7 +429,7 @@ AM_CONDITIONAL([ENABLE_BASH], [test "x$enable_bash" = "xyes"])
+ AM_COND_IF([ENABLE_BASH],
+ [AC_MSG_CHECKING([bash completion directory])
+ PKG_CHECK_VAR(bashcompdir, [bash-completion], [completionsdir], ,
+- bashcompdir="${sysconfdir}/bash_completion.d")
++ bashcompdir="$datadir/bash-completion/completions")
+ AC_MSG_RESULT([$bashcompdir])
+ AC_SUBST(bashcompdir)
+ ])
diff --git a/app-emulation/lxc/files/lxc-1.0.11-major.patch b/app-emulation/lxc/files/lxc-1.0.11-major.patch
new file mode 100644
index 000000000000..8a3c2b2bd6d3
--- /dev/null
+++ b/app-emulation/lxc/files/lxc-1.0.11-major.patch
@@ -0,0 +1,64 @@
+diff --git a/src/lxc/bdev.c b/src/lxc/bdev.c
+index 59eda7e4..44b71d4c 100644
+--- a/src/lxc/bdev.c
++++ b/src/lxc/bdev.c
+@@ -41,6 +41,7 @@
+ #include <libgen.h>
+ #include <linux/loop.h>
+ #include <dirent.h>
++#include <sys/sysmacros.h>
+
+ #include "lxc.h"
+ #include "config.h"
+@@ -58,9 +59,6 @@
+ #ifdef MAJOR_IN_MKDEV
+ # include <sys/mkdev.h>
+ #endif
+-#ifdef MAJOR_IN_SYSMACROS
+-# include <sys/sysmacros.h>
+-#endif
+
+ #ifndef BLKGETSIZE64
+ #define BLKGETSIZE64 _IOR(0x12,114,size_t)
+diff --git a/src/lxc/conf.c b/src/lxc/conf.c
+index 5d583d5f..d4217c27 100644
+--- a/src/lxc/conf.c
++++ b/src/lxc/conf.c
+@@ -36,14 +36,12 @@
+ #include <pwd.h>
+ #include <grp.h>
+ #include <time.h>
++#include <sys/sysmacros.h>
+
+ /* makedev() */
+ #ifdef MAJOR_IN_MKDEV
+ # include <sys/mkdev.h>
+ #endif
+-#ifdef MAJOR_IN_SYSMACROS
+-# include <sys/sysmacros.h>
+-#endif
+
+ #ifdef HAVE_STATVFS
+ #include <sys/statvfs.h>
+diff --git a/src/lxc/lxccontainer.c b/src/lxc/lxccontainer.c
+index 3963a3ee..30ac6733 100644
+--- a/src/lxc/lxccontainer.c
++++ b/src/lxc/lxccontainer.c
+@@ -36,6 +36,7 @@
+ #include <stdint.h>
+ #include <grp.h>
+ #include <sys/syscall.h>
++#include <sys/sysmacros.h>
+
+ #include <lxc/lxccontainer.h>
+ #include <lxc/version.h>
+@@ -60,9 +61,6 @@
+ #ifdef MAJOR_IN_MKDEV
+ # include <sys/mkdev.h>
+ #endif
+-#ifdef MAJOR_IN_SYSMACROS
+-# include <sys/sysmacros.h>
+-#endif
+
+ #if HAVE_IFADDRS_H
+ #include <ifaddrs.h>