summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2016-12-03 21:30:30 +0800
committerYixun Lan <dlan@gentoo.org>2016-12-03 21:38:51 +0800
commit2891603788e6f92f8c58ea74d26a48e62c3c21ab (patch)
tree6918f6ed3a5f8ff7068d5d18467457fc5ff740c5 /app-emulation/lxc/files
parentsys-fs/fuse-zip: Version bump. Remove old (diff)
downloadgentoo-2891603788e6f92f8c58ea74d26a48e62c3c21ab.tar.gz
gentoo-2891603788e6f92f8c58ea74d26a48e62c3c21ab.tar.bz2
gentoo-2891603788e6f92f8c58ea74d26a48e62c3c21ab.zip
app-emulation/lxc: version bump
rework bashcomp patch to make 2.0.6 happy Package-Manager: portage-2.3.2
Diffstat (limited to 'app-emulation/lxc/files')
-rw-r--r--app-emulation/lxc/files/lxc-2.0.6-bash-completion.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-emulation/lxc/files/lxc-2.0.6-bash-completion.patch b/app-emulation/lxc/files/lxc-2.0.6-bash-completion.patch
new file mode 100644
index 000000000000..6033e36c7985
--- /dev/null
+++ b/app-emulation/lxc/files/lxc-2.0.6-bash-completion.patch
@@ -0,0 +1,27 @@
+diff --git a/config/bash/lxc.in b/config/bash/lxc.in
+index 7dcf302..5927fe2 100644
+--- a/config/bash/lxc.in
++++ b/config/bash/lxc.in
+@@ -1,4 +1,3 @@
+-_have lxc-start && {
+ _lxc_names() {
+ COMPREPLY=( $( compgen -W "$( lxc-ls )" "$cur" ) )
+ }
+@@ -100,4 +99,3 @@ _have lxc-start && {
+
+ complete -o default -F _lxc_generic_o lxc-copy
+ complete -o default -F _lxc_generic_o lxc-start-ephemeral
+-}
+diff --git a/configure.ac b/configure.ac
+index 4640c0d..14ccdd3 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -478,7 +478,7 @@ AM_CONDITIONAL([ENABLE_BASH], [test "x$enable_bash" = "xyes"])
+ AM_COND_IF([ENABLE_BASH],
+ [AC_MSG_CHECKING([bash completion directory])
+ PKG_CHECK_VAR(bashcompdir, [bash-completion], [completionsdir], ,
+- bashcompdir="${sysconfdir}/bash_completion.d")
++ bashcompdir="$datadir/bash-completion/completions")
+ AC_MSG_RESULT([$bashcompdir])
+ AC_SUBST(bashcompdir)
+ ])