summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2017-12-27 09:32:51 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-01-03 12:06:43 +0100
commit82fc7433c33e2356188503b0e58e4c74bb2e8542 (patch)
treed84054753e4cec06d768f84c8e8a6e49f77deeaf /app-emulation/lxc/files
parentapp-office/openerp: remove unused patch. (diff)
downloadgentoo-82fc7433c33e2356188503b0e58e4c74bb2e8542.tar.gz
gentoo-82fc7433c33e2356188503b0e58e4c74bb2e8542.tar.bz2
gentoo-82fc7433c33e2356188503b0e58e4c74bb2e8542.zip
app-emulation/lxc: remove unused patch.
Closes: https://github.com/gentoo/gentoo/pull/6648
Diffstat (limited to 'app-emulation/lxc/files')
-rw-r--r--app-emulation/lxc/files/lxc-2.0.6-major.patch74
1 files changed, 0 insertions, 74 deletions
diff --git a/app-emulation/lxc/files/lxc-2.0.6-major.patch b/app-emulation/lxc/files/lxc-2.0.6-major.patch
deleted file mode 100644
index beb379a53882..000000000000
--- a/app-emulation/lxc/files/lxc-2.0.6-major.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-Adapt to future removal of major()/minor()/makedev() from <sys/types.h>
-
-Gentoo removed it in glibc-2.24.
-
-https://bugs.gentoo.org/575232
-https://bugs.gentoo.org/604360
-diff --git a/configure.ac b/configure.ac
-index 4640c0d..71e6450 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -620,4 +620,7 @@ AC_CHECK_DECLS([PR_CAPBSET_DROP], [], [], [#include <sys/prctl.h>])
- AC_CHECK_HEADERS([sys/signalfd.h pty.h ifaddrs.h sys/capability.h sys/personality.h utmpx.h sys/timerfd.h])
-
-+# lookup major()/minor()/makedev()
-+AC_HEADER_MAJOR
-+
- # Check for some syscalls functions
- AC_CHECK_FUNCS([setns pivot_root sethostname unshare rand_r confstr faccessat])
-diff --git a/src/lxc/bdev/lxclvm.c b/src/lxc/bdev/lxclvm.c
-index 3d41b10..419d1c2 100644
---- a/src/lxc/bdev/lxclvm.c
-+++ b/src/lxc/bdev/lxclvm.c
-@@ -33,8 +33,17 @@
-
- #include "bdev.h"
-+#include "config.h"
- #include "log.h"
- #include "lxclvm.h"
- #include "utils.h"
-
-+/* major()/minor() */
-+#ifdef MAJOR_IN_MKDEV
-+# include <sys/mkdev.h>
-+#endif
-+#ifdef MAJOR_IN_SYSMACROS
-+# include <sys/sysmacros.h>
-+#endif
-+
- lxc_log_define(lxclvm, lxc);
-
-diff --git a/src/lxc/conf.c b/src/lxc/conf.c
-index c54ee41..9a00e7f 100644
---- a/src/lxc/conf.c
-+++ b/src/lxc/conf.c
-@@ -40,4 +40,12 @@
- #include <time.h>
-
-+/* makedev() */
-+#ifdef MAJOR_IN_MKDEV
-+# include <sys/mkdev.h>
-+#endif
-+#ifdef MAJOR_IN_SYSMACROS
-+# include <sys/sysmacros.h>
-+#endif
-+
- #ifdef HAVE_STATVFS
- #include <sys/statvfs.h>
-diff --git a/src/lxc/lxccontainer.c b/src/lxc/lxccontainer.c
-index 3a9e1e3..fe75fcc 100644
---- a/src/lxc/lxccontainer.c
-+++ b/src/lxc/lxccontainer.c
-@@ -62,4 +62,12 @@
- #include "version.h"
-
-+/* major()/minor() */
-+#ifdef MAJOR_IN_MKDEV
-+# include <sys/mkdev.h>
-+#endif
-+#ifdef MAJOR_IN_SYSMACROS
-+# include <sys/sysmacros.h>
-+#endif
-+
- #if HAVE_IFADDRS_H
- #include <ifaddrs.h>