summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2015-09-05 09:06:36 +0100
committerMarkos Chandras <hwoarang@gentoo.org>2015-09-05 09:08:23 +0100
commitded368f9a246102c62a83377408b4b8ba489129f (patch)
tree0f348dcd0ce66b69cf2f4deeb748bee8b6807e00 /app-emulation/lxc/files
parentapp-emulation/lxc: Improve init script for shutting down containers. Bug #556826 (diff)
downloadgentoo-ded368f9a246102c62a83377408b4b8ba489129f.tar.gz
gentoo-ded368f9a246102c62a83377408b4b8ba489129f.tar.bz2
gentoo-ded368f9a246102c62a83377408b4b8ba489129f.zip
app-emulation/lxc: Version bump
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'app-emulation/lxc/files')
-rw-r--r--app-emulation/lxc/files/lxc-1.1.3-bash-completion.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-emulation/lxc/files/lxc-1.1.3-bash-completion.patch b/app-emulation/lxc/files/lxc-1.1.3-bash-completion.patch
new file mode 100644
index 000000000000..3bcb40c65a65
--- /dev/null
+++ b/app-emulation/lxc/files/lxc-1.1.3-bash-completion.patch
@@ -0,0 +1,35 @@
+Index: lxc-lxc-1.1.3/config/bash/Makefile.am
+===================================================================
+--- lxc-lxc-1.1.3.orig/config/bash/Makefile.am
++++ lxc-lxc-1.1.3/config/bash/Makefile.am
+@@ -2,12 +2,12 @@ EXTRA_DIST = lxc
+
+ if ENABLE_BASH
+ install-bash:
+- $(MKDIR_P) $(DESTDIR)$(sysconfdir)/bash_completion.d/
+- $(INSTALL_DATA) lxc $(DESTDIR)$(sysconfdir)/bash_completion.d/
++ $(MKDIR_P) $(DESTDIR)$(datarootdir)/bash-completion/completions//
++ $(INSTALL_DATA) lxc $(DESTDIR)$(datarootdir)/bash-completion/completions/
+
+ uninstall-bash:
+- rm -f $(DESTDIR)$(sysconfdir)/bash_completion.d/lxc
+- rmdir $(DESTDIR)$(sysconfdir)/bash_completion.d/ || :
++ rm -f $(DESTDIR)$(datarootdir)/bash-completion/completions/lxc
++ rmdir $(DESTDIR)$(datarootdir)/bash-completion/ || :
+
+ install-data-local: install-bash
+ uninstall-local: uninstall-bash
+Index: lxc-lxc-1.1.3/config/bash/lxc.in
+===================================================================
+--- lxc-lxc-1.1.3.orig/config/bash/lxc.in
++++ lxc-lxc-1.1.3/config/bash/lxc.in
+@@ -1,4 +1,3 @@
+-have lxc-start && {
+ _lxc_names() {
+ COMPREPLY=( $( compgen -W "$( lxc-ls )" "$cur" ) )
+ }
+@@ -100,4 +99,3 @@ have lxc-start && {
+
+ complete -o default -F _lxc_generic_o lxc-clone
+ complete -o default -F _lxc_generic_o lxc-start-ephemeral
+-}