summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2015-12-06 16:49:09 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2015-12-06 18:54:07 +0000
commite5087471168deb08473cbbd2d1b62d4758e99110 (patch)
tree27dc0c237afc4ca5dd0e8fd45d965b23381182a1 /app-emulation/lxc/files
parentdev-libs/libbsd: Version bump to 0.8.0 (diff)
downloadgentoo-e5087471168deb08473cbbd2d1b62d4758e99110.tar.gz
gentoo-e5087471168deb08473cbbd2d1b62d4758e99110.tar.bz2
gentoo-e5087471168deb08473cbbd2d1b62d4758e99110.zip
app-emulation/lxc: Version bump. Bug #565688
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-emulation/lxc/files')
-rw-r--r--app-emulation/lxc/files/lxc-1.0.8-bash-completion.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-emulation/lxc/files/lxc-1.0.8-bash-completion.patch b/app-emulation/lxc/files/lxc-1.0.8-bash-completion.patch
new file mode 100644
index 000000000000..e9e0e6c98dfd
--- /dev/null
+++ b/app-emulation/lxc/files/lxc-1.0.8-bash-completion.patch
@@ -0,0 +1,35 @@
+Index: lxc-lxc-1.0.8/config/bash/Makefile.am
+===================================================================
+--- lxc-lxc-1.0.8.orig/config/bash/Makefile.am
++++ lxc-lxc-1.0.8/config/bash/Makefile.am
+@@ -2,12 +2,12 @@ EXTRA_DIST = lxc
+
+ if ENABLE_BASH
+ install-bash:
+- $(MKDIR_P) $(DESTDIR)$(sysconfdir)/bash_completion.d/
+- $(INSTALL_DATA) lxc $(DESTDIR)$(sysconfdir)/bash_completion.d/
++ $(MKDIR_P) $(DESTDIR)$(datarootdir)/bash-completion/completions/
++ $(INSTALL_DATA) lxc $(DESTDIR)$(datarootdir)/bash-completion/completions/
+
+ uninstall-bash:
+- rm -f $(DESTDIR)$(sysconfdir)/bash_completion.d/lxc
+- rmdir $(DESTDIR)$(sysconfdir)/bash_completion.d/ || :
++ rm -f $(DESTDIR)$(datarootdir)/bash-completion/completions/lxc
++ rmdir $(DESTDIR)$(datarootdir)/bash-completion// || :
+
+ install-data-local: install-bash
+ uninstall-local: uninstall-bash
+Index: lxc-lxc-1.0.8/config/bash/lxc.in
+===================================================================
+--- lxc-lxc-1.0.8.orig/config/bash/lxc.in
++++ lxc-lxc-1.0.8/config/bash/lxc.in
+@@ -1,4 +1,3 @@
+-have lxc-start && {
+ _lxc_names() {
+ COMPREPLY=( $( compgen -W "$( lxc-ls )" "$cur" ) )
+ }
+@@ -100,4 +99,3 @@ have lxc-start && {
+
+ complete -o default -F _lxc_generic_o lxc-clone
+ complete -o default -F _lxc_generic_o lxc-start-ephemeral
+-}