summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2017-02-23 13:52:33 -0600
committerMatthias Maier <tamiko@gentoo.org>2017-02-23 14:24:19 -0600
commit1e24caf48e8abc0e6410256fc5c20acc7d862b9a (patch)
tree3c7636d21b5f279604f4b0b1e5449858d414ca5c /app-emulation/qemu
parentapp-emulation/qemu: Dynamically create binfmt.d/qemu.conf (diff)
downloadgentoo-1e24caf48e8abc0e6410256fc5c20acc7d862b9a.tar.gz
gentoo-1e24caf48e8abc0e6410256fc5c20acc7d862b9a.tar.bz2
gentoo-1e24caf48e8abc0e6410256fc5c20acc7d862b9a.zip
app-emulation/qemu: Update readme in 9999 to reflect latest changes
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-emulation/qemu')
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild50
1 files changed, 25 insertions, 25 deletions
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index 3f97bbab457c..b919ffecd689 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -212,27 +212,26 @@ QA_WX_LOAD="usr/bin/qemu-i386
usr/bin/qemu-s390x
usr/bin/qemu-unicore32"
-DOC_CONTENTS="If you don't have kvm compiled into the kernel, make sure
-you have the kernel module loaded before running kvm. The easiest way to
-ensure that the kernel module is loaded is to load it on boot.\n
-For AMD CPUs the module is called 'kvm-amd'.\n
-For Intel CPUs the module is called 'kvm-intel'.\n
-Please review /etc/conf.d/modules for how to load these.\n\n
-Make sure your user is in the 'kvm' group\n
-Just run 'gpasswd -a <USER> kvm', then have <USER> re-login.\n\n
-For brand new installs, the default permissions on /dev/kvm might not let you
-access it. You can tell udev to reset ownership/perms:\n
-udevadm trigger -c add /dev/kvm"
-
-qemu_support_kvm() {
- if use qemu_softmmu_targets_x86_64 || use qemu_softmmu_targets_i386 \
- use qemu_softmmu_targets_ppc || use qemu_softmmu_targets_ppc64 \
- use qemu_softmmu_targets_s390x; then
- return 0
- fi
-
- return 1
-}
+DOC_CONTENTS="If you don't have kvm compiled into the kernel, make sure you have the
+kernel module loaded before running kvm. The easiest way to ensure that the
+kernel module is loaded is to load it on boot.
+ For AMD CPUs the module is called 'kvm-amd'.
+ For Intel CPUs the module is called 'kvm-intel'.
+Please review /etc/conf.d/modules for how to load these.
+
+Make sure your user is in the 'kvm' group. Just run
+ $ gpasswd -a <USER> kvm
+then have <USER> re-login.
+
+For brand new installs, the default permissions on /dev/kvm might not let
+you access it. You can tell udev to reset ownership/perms:
+ $ udevadm trigger -c add /dev/kvm
+
+If you want to register binfmt handlers for qemu user targets:
+For openrc:
+ # rc-update add qemu-binfmt
+For systemd:
+ # ln -s /usr/share/qemu/binfmt.d/qemu.conf /etc/binfmt.d/qemu.conf"
pkg_pretend() {
if use kernel_linux && kernel_is lt 2 6 25; then
@@ -702,13 +701,14 @@ src_install() {
fi
fi
- qemu_support_kvm && readme.gentoo_create_doc
+ DISABLE_AUTOFORMATTING=true
+ readme.gentoo_create_doc
}
pkg_postinst() {
- if qemu_support_kvm; then
- readme.gentoo_print_elog
- fi
+ DISABLE_AUTOFORMATTING=true
+ FORCE_PRINT_ELOG=1 # remove for next version bump
+ readme.gentoo_print_elog
if [[ -n ${softmmu_targets} ]] && use kernel_linux; then
udev_reload