summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Privoznik <mprivozn@redhat.com>2018-10-22 14:21:08 +0100
committerMatthias Maier <tamiko@gentoo.org>2018-10-22 09:38:07 -0500
commit5d79df3753917c3f2c7ef22fdb3e2d0bfb2b33f9 (patch)
tree84bf3f4cd45f4f3ab1826717432b87189fe30d04 /app-emulation/qemu
parentapp-emulation/qemu-9999: Drop gtk2 use flag (diff)
downloadgentoo-5d79df3753917c3f2c7ef22fdb3e2d0bfb2b33f9.tar.gz
gentoo-5d79df3753917c3f2c7ef22fdb3e2d0bfb2b33f9.tar.bz2
gentoo-5d79df3753917c3f2c7ef22fdb3e2d0bfb2b33f9.zip
app-emulation/qemu-9999: Drop sdl-1.2 support
QEMU has deprecated sdl-1.2 support nearly a year ago (in upstream commit of e52c6ba3414). It's not removed yet, but it soon will be. Therefore, drop support for it in our ebuild. This is achieved by basically dropping old 'sdl' use flag and then renaming 'sdl2' to 'sdl'. Signed-off-by: Michal Privoznik <mprivozn@redhat.com> Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'app-emulation/qemu')
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild15
1 files changed, 4 insertions, 11 deletions
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index 555a20f9237d..b33e04e51528 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -30,7 +30,7 @@ SLOT="0"
IUSE="accessibility +aio alsa bluetooth bzip2 capstone +caps +curl debug
+fdt glusterfs gnutls gtk infiniband iscsi +jpeg kernel_linux
kernel_FreeBSD lzo ncurses nfs nls numa opengl +pin-upstream-blobs +png
- pulseaudio python rbd sasl +seccomp sdl sdl2 selinux smartcard snappy
+ pulseaudio python rbd sasl +seccomp sdl selinux smartcard snappy
spice ssh static static-user systemtap tci test usb usbredir vde
+vhost-net virgl virtfs +vnc vte xattr xen xfs"
@@ -55,7 +55,6 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
qemu_softmmu_targets_mips64el? ( fdt )
qemu_softmmu_targets_ppc? ( fdt )
qemu_softmmu_targets_ppc64? ( fdt )
- sdl2? ( sdl )
static? ( static-user !alsa !bluetooth !gtk !opengl !pulseaudio !snappy )
virtfs? ( xattr )
vte? ( gtk )"
@@ -127,14 +126,8 @@ SOFTMMU_TOOLS_DEPEND="
rbd? ( sys-cluster/ceph[static-libs(+)] )
sasl? ( dev-libs/cyrus-sasl[static-libs(+)] )
sdl? (
- !sdl2? (
- media-libs/libsdl[X]
- >=media-libs/libsdl-1.2.11[static-libs(+)]
- )
- sdl2? (
- media-libs/libsdl2[X]
- media-libs/libsdl2[static-libs(+)]
- )
+ media-libs/libsdl2[X]
+ media-libs/libsdl2[static-libs(+)]
)
seccomp? ( >=sys-libs/libseccomp-2.1.0[static-libs(+)] )
smartcard? ( >=app-emulation/libcacard-2.5.0[static-libs(+)] )
@@ -488,7 +481,7 @@ qemu_src_configure() {
conf_opts+=(
--audio-drv-list="${audio_opts}"
)
- use sdl && conf_opts+=( --with-sdlabi=$(usex sdl2 2.0 1.2) )
+ use sdl && conf_opts+=( --with-sdlabi=2.0 )
fi
case ${buildtype} in