summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-12-07 22:54:04 -0500
committerMike Frysinger <vapier@gentoo.org>2015-12-07 22:54:04 -0500
commit5e0322ce76178299b66f15933bc0a2c2a384bd3c (patch)
tree3897505b7234f8db19349ac17b2d5828ce452a82 /app-emulation/qemu
parentmedia-libs/virglrenderer: initial package #566992 (diff)
downloadgentoo-5e0322ce76178299b66f15933bc0a2c2a384bd3c.tar.gz
gentoo-5e0322ce76178299b66f15933bc0a2c2a384bd3c.tar.bz2
gentoo-5e0322ce76178299b66f15933bc0a2c2a384bd3c.zip
app-emulation/qemu: add USE=virgl for Virgil 3d GPU #566994
Diffstat (limited to 'app-emulation/qemu')
-rw-r--r--app-emulation/qemu/metadata.xml1
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild4
2 files changed, 4 insertions, 1 deletions
diff --git a/app-emulation/qemu/metadata.xml b/app-emulation/qemu/metadata.xml
index 4a344007d8cb..d282a753b64a 100644
--- a/app-emulation/qemu/metadata.xml
+++ b/app-emulation/qemu/metadata.xml
@@ -42,6 +42,7 @@
<flag name="uuid">Enable UUID support in the vdi block driver</flag>
<flag name="vde">Enable VDE-based networking</flag>
<flag name="vhost-net">Enable accelerated networking using vhost-net, see http://www.linux-kvm.org/page/VhostNet</flag>
+ <flag name="virgl">Enable experimental Virgil 3d (virtual software GPU)</flag>
<flag name="virtfs">Enable VirtFS via virtio-9p-pci / fsdev. See http://wiki.qemu.org/Documentation/9psetup</flag>
<flag name="vte">Enable terminal support (<pkg>x11-libs/vte</pkg>) in the GTK+ interface</flag>
<flag name="xattr">Add support for getting and setting POSIX extended attributes, through
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index 4ca906c5d930..963ea6b2cd48 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -34,7 +34,7 @@ kernel_linux kernel_FreeBSD lzo ncurses nfs nls numa opengl +pin-upstream-blobs
+png pulseaudio python \
rbd sasl +seccomp sdl sdl2 selinux smartcard snappy spice ssh static static-softmmu
static-user systemtap tci test +threads usb usbredir +uuid vde +vhost-net \
-virtfs +vnc vte xattr xen xfs"
+virgl virtfs +vnc vte xattr xen xfs"
COMMON_TARGETS="aarch64 alpha arm cris i386 m68k microblaze microblazeel mips
mips64 mips64el mipsel or32 ppc ppc64 s390x sh4 sh4eb sparc sparc64 unicore32
@@ -134,6 +134,7 @@ SOFTMMU_LIB_DEPEND="${COMMON_LIB_DEPEND}
usbredir? ( >=sys-apps/usbredir-0.6[static-libs(+)] )
uuid? ( >=sys-apps/util-linux-2.16.0[static-libs(+)] )
vde? ( net-misc/vde[static-libs(+)] )
+ virgl? ( media-libs/virglrenderer[static-libs(+)] )
virtfs? ( sys-libs/libcap )
xfs? ( sys-fs/xfsprogs[static-libs(+)] )"
USER_LIB_DEPEND="${COMMON_LIB_DEPEND}"
@@ -395,6 +396,7 @@ qemu_src_configure() {
$(conf_softmmu uuid)
$(conf_softmmu vde)
$(conf_softmmu vhost-net)
+ $(conf_softmmu virgl virglrenderer)
$(conf_softmmu virtfs)
$(conf_softmmu vnc)
$(conf_softmmu vte)