summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2019-09-22 00:06:31 +0100
committerMatthias Maier <tamiko@gentoo.org>2019-09-21 21:12:19 -0500
commit6bf5d3588d050b988ad838591404fb0545b6d416 (patch)
treed78996bc6ebdda4223e691d9cdd3ae3e41a938d9 /app-emulation/qemu
parentapp-emulation/qemu: Add oss USE flag instead of always enabling (diff)
downloadgentoo-6bf5d3588d050b988ad838591404fb0545b6d416.tar.gz
gentoo-6bf5d3588d050b988ad838591404fb0545b6d416.tar.bz2
gentoo-6bf5d3588d050b988ad838591404fb0545b6d416.zip
app-emulation/qemu: Fix cross-compiling for MinGW (Windows)
Yes, this really works! By default, the configure script shoves everything in the same standalone directory for Windows, hence the need to specify more paths. It doesn't work from a standalone directory unless you build it statically anyway because it can't find the dependent DLLs in /usr/bin. Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: James Le Cuirot <chewi@gentoo.org> Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'app-emulation/qemu')
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index 58a7d0b85807..b26d0b2869df 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -363,8 +363,9 @@ src_prepare() {
default
- # Fix ld and objcopy being called directly
- tc-export AR LD OBJCOPY
+ # Use correct toolchain to fix cross-compiling
+ tc-export AR LD NM OBJCOPY PKG_CONFIG
+ export WINDRES=${CHOST}-windres
# Verbose builds
MAKEOPTS+=" V=1"
@@ -391,8 +392,13 @@ qemu_src_configure() {
local conf_opts=(
--prefix=/usr
--sysconfdir=/etc
+ --bindir=/usr/bin
--libdir=/usr/$(get_libdir)
+ --datadir=/usr/share
--docdir=/usr/share/doc/${PF}/html
+ --mandir=/usr/share/man
+ --with-confsuffix=/qemu
+ --localstatedir=/var
--disable-bsd-user
--disable-guest-agent
--disable-strip