summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-12 15:55:15 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-12 15:58:31 +0100
commitd5b19bbff6ccd02d32b24c5fb7af6e4b20ec3727 (patch)
tree7db911448e2115e05c50f4256990c98018392dbb /app-emulation/qemu
parentdev-ros/ament_cmake_export_dependencies: fix deps, add live ebuild (diff)
downloadgentoo-d5b19bbff6ccd02d32b24c5fb7af6e4b20ec3727.tar.gz
gentoo-d5b19bbff6ccd02d32b24c5fb7af6e4b20ec3727.tar.bz2
gentoo-d5b19bbff6ccd02d32b24c5fb7af6e4b20ec3727.zip
app-emulation/qemu: Fix MissingTestRestrict
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-emulation/qemu')
-rw-r--r--app-emulation/qemu/qemu-4.0.0-r50.ebuild1
-rw-r--r--app-emulation/qemu/qemu-4.1.0.ebuild1
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild1
3 files changed, 3 insertions, 0 deletions
diff --git a/app-emulation/qemu/qemu-4.0.0-r50.ebuild b/app-emulation/qemu/qemu-4.0.0-r50.ebuild
index d585d58e2726..428fbaafe4df 100644
--- a/app-emulation/qemu/qemu-4.0.0-r50.ebuild
+++ b/app-emulation/qemu/qemu-4.0.0-r50.ebuild
@@ -47,6 +47,7 @@ use_softmmu_targets=$(printf ' qemu_softmmu_targets_%s' ${IUSE_SOFTMMU_TARGETS})
use_user_targets=$(printf ' qemu_user_targets_%s' ${IUSE_USER_TARGETS})
IUSE+=" ${use_softmmu_targets} ${use_user_targets}"
+RESTRICT="!test? ( test )"
# Allow no targets to be built so that people can get a tools-only build.
# Block USE flag configurations known to not work.
REQUIRED_USE="${PYTHON_REQUIRED_USE}
diff --git a/app-emulation/qemu/qemu-4.1.0.ebuild b/app-emulation/qemu/qemu-4.1.0.ebuild
index d0bec4380dbc..e8f34c66cab1 100644
--- a/app-emulation/qemu/qemu-4.1.0.ebuild
+++ b/app-emulation/qemu/qemu-4.1.0.ebuild
@@ -53,6 +53,7 @@ use_softmmu_targets=$(printf ' qemu_softmmu_targets_%s' ${IUSE_SOFTMMU_TARGETS})
use_user_targets=$(printf ' qemu_user_targets_%s' ${IUSE_USER_TARGETS})
IUSE+=" ${use_softmmu_targets} ${use_user_targets}"
+RESTRICT="!test? ( test )"
# Allow no targets to be built so that people can get a tools-only build.
# Block USE flag configurations known to not work.
REQUIRED_USE="${PYTHON_REQUIRED_USE}
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index d024b5020691..3bf1f06000f9 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -53,6 +53,7 @@ use_softmmu_targets=$(printf ' qemu_softmmu_targets_%s' ${IUSE_SOFTMMU_TARGETS})
use_user_targets=$(printf ' qemu_user_targets_%s' ${IUSE_USER_TARGETS})
IUSE+=" ${use_softmmu_targets} ${use_user_targets}"
+RESTRICT="!test? ( test )"
# Allow no targets to be built so that people can get a tools-only build.
# Block USE flag configurations known to not work.
REQUIRED_USE="${PYTHON_REQUIRED_USE}