summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emulation/qtemu
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emulation/qtemu')
-rw-r--r--app-emulation/qtemu/Manifest1
-rw-r--r--app-emulation/qtemu/files/1.0.5-help_and_translation_paths.patch63
-rw-r--r--app-emulation/qtemu/metadata.xml10
-rw-r--r--app-emulation/qtemu/qtemu-1.0.5.ebuild32
4 files changed, 106 insertions, 0 deletions
diff --git a/app-emulation/qtemu/Manifest b/app-emulation/qtemu/Manifest
new file mode 100644
index 000000000000..7d80d3725c8a
--- /dev/null
+++ b/app-emulation/qtemu/Manifest
@@ -0,0 +1 @@
+DIST qtemu-1.0.5.tar.bz2 555872 SHA256 752942fae239996c826580fd0b32986cf96a92a0982710f726947ddf791dc921 SHA512 c8380acea500453053d8d2a9cc3eecb51c766d5743a22a7fbe13d3bd5d543ab63ab715ac2ffbd2389f24c699ea81ca3e0584c7578a9799300cef514886d1cee8 WHIRLPOOL 7ca11b4da2961385511b830e397bc63a1a648bc5fe37c4eca1d658623a15ad6a5346ae06ce39ed168421cdcdbe12de32019fbd7c1e9a8afc9ff0509199d57fa5
diff --git a/app-emulation/qtemu/files/1.0.5-help_and_translation_paths.patch b/app-emulation/qtemu/files/1.0.5-help_and_translation_paths.patch
new file mode 100644
index 000000000000..8fc1680aacb0
--- /dev/null
+++ b/app-emulation/qtemu/files/1.0.5-help_and_translation_paths.patch
@@ -0,0 +1,63 @@
+diff -Naur qtemu-1.0.5.orig/CMakeLists.txt qtemu-1.0.5/CMakeLists.txt
+--- qtemu-1.0.5.orig/CMakeLists.txt 2008-02-22 19:32:43.000000000 +0100
++++ qtemu-1.0.5/CMakeLists.txt 2008-02-22 19:35:29.000000000 +0100
+@@ -114,7 +114,7 @@
+ DEPENDS ${QM_FILES})
+
+ INSTALL (FILES ${QM_FILES}
+- DESTINATION translations)
++ DESTINATION share/qtemu/translations)
+ # translation end
+
+ SET(QT_USE_QTXML)
+@@ -146,13 +146,13 @@
+ )
+
+ FILE(GLOB helpfiles "${CMAKE_CURRENT_SOURCE_DIR}/help/*.png")
+-INSTALL(FILES ${helpfiles} DESTINATION help)
++INSTALL(FILES ${helpfiles} DESTINATION share/qtemu/help)
+
+-INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/help/main.htm DESTINATION help)
++INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/help/main.htm DESTINATION share/qtemu/help)
+
+ FILE(GLOB helpfiles_de "${CMAKE_CURRENT_SOURCE_DIR}/help/de/*.png")
+-INSTALL(FILES ${helpfiles_de} DESTINATION help/de)
++INSTALL(FILES ${helpfiles_de} DESTINATION share/qtemu/help/de)
+
+-INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/help/de/main.htm DESTINATION help/de)
++INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/help/de/main.htm DESTINATION share/qtemu/help/de)
+
+ INSTALL(TARGETS qtemu DESTINATION bin)
+diff -Naur qtemu-1.0.5.orig/helpwindow.cpp qtemu-1.0.5/helpwindow.cpp
+--- qtemu-1.0.5.orig/helpwindow.cpp 2008-02-22 19:32:44.000000000 +0100
++++ qtemu-1.0.5/helpwindow.cpp 2008-02-22 19:33:26.000000000 +0100
+@@ -80,7 +80,7 @@
+ return testUrl;
+
+ //check for case when qtemu executable is in bin/ (installed on linux)
+- testUrl = QUrl(QCoreApplication::applicationDirPath()+"/../help/" + locale + "/main.htm");
++ testUrl = QUrl(QCoreApplication::applicationDirPath()+"/../share/qtemu/help/" + locale + "/main.htm");
+ if (QFile::exists(testUrl.toString()))
+ return testUrl;
+ }
+@@ -96,7 +96,7 @@
+ return testUrl;
+
+ //check for case when qtemu executable is in bin/ (installed on linux)
+- testUrl = QUrl(QCoreApplication::applicationDirPath()+"/../help/main.htm");
++ testUrl = QUrl(QCoreApplication::applicationDirPath()+"/../share/qtemu/help/main.htm");
+ if (QFile::exists(testUrl.toString()))
+ return testUrl;
+
+diff -Naur qtemu-1.0.5.orig/main.cpp qtemu-1.0.5/main.cpp
+--- qtemu-1.0.5.orig/main.cpp 2008-02-22 19:32:43.000000000 +0100
++++ qtemu-1.0.5/main.cpp 2008-02-22 19:36:32.000000000 +0100
+@@ -45,7 +45,7 @@
+ translator.load(path);
+ else
+ {
+- path = QCoreApplication::applicationDirPath()+"/../translations/qtemu_" + locale + ".qm";
++ path = QCoreApplication::applicationDirPath()+"/../share/qtemu/translations/qtemu_" + locale + ".qm";
+ if (QFile::exists(path))
+ translator.load(path);
+ }
diff --git a/app-emulation/qtemu/metadata.xml b/app-emulation/qtemu/metadata.xml
new file mode 100644
index 000000000000..6f617db635ac
--- /dev/null
+++ b/app-emulation/qtemu/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">qtemu</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emulation/qtemu/qtemu-1.0.5.ebuild b/app-emulation/qtemu/qtemu-1.0.5.ebuild
new file mode 100644
index 000000000000..9adc53e7c3cd
--- /dev/null
+++ b/app-emulation/qtemu/qtemu-1.0.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils cmake-utils
+
+DESCRIPTION="A graphical user interface for QEMU written in Qt4"
+HOMEPAGE="http://qtemu.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1 CC-BY-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtcore:4
+ dev-qt/qtgui:4"
+RDEPEND="${DEPEND}
+ app-emulation/qemu"
+
+DOCS=( ChangeLog README )
+PATCHES=(
+ "${FILESDIR}/${PV}-help_and_translation_paths.patch"
+)
+
+src_install() {
+ cmake-utils_src_install
+ doicon "${S}/images/${PN}.ico"
+ make_desktop_entry "qtemu" "QtEmu" "${PN}.ico" "Qt;Utility;Emulator"
+}