summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2016-11-09 13:23:38 -0600
committerWilliam Hubbs <williamh@gentoo.org>2016-11-09 13:25:27 -0600
commit3766a80791217dd04646e4c4a4f8da0c43546e26 (patch)
tree103fef5fd5a8c8a4f142a1944724e0d20d5d0965 /app-emulation/runc
parentgr-rftap: and why not (diff)
downloadgentoo-3766a80791217dd04646e4c4a4f8da0c43546e26.tar.gz
gentoo-3766a80791217dd04646e4c4a4f8da0c43546e26.tar.bz2
gentoo-3766a80791217dd04646e4c4a4f8da0c43546e26.zip
app-emulation/runc: 1.0.0_rc2 Add hardened support
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-emulation/runc')
-rw-r--r--app-emulation/runc/runc-1.0.0_rc2.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/app-emulation/runc/runc-1.0.0_rc2.ebuild b/app-emulation/runc/runc-1.0.0_rc2.ebuild
index 0844ed4146cc..da27cda50ffe 100644
--- a/app-emulation/runc/runc-1.0.0_rc2.ebuild
+++ b/app-emulation/runc/runc-1.0.0_rc2.ebuild
@@ -20,7 +20,7 @@ HOMEPAGE="http://runc.io"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="apparmor +seccomp"
+IUSE="apparmor hardened +seccomp"
DEPEND=""
RDEPEND="
@@ -33,7 +33,8 @@ S=${WORKDIR}/${P}/src/${EGO_PN}
src_compile() {
# Taken from app-emulation/docker-1.7.0-r1
export CGO_CFLAGS="-I${ROOT}/usr/include"
- export CGO_LDFLAGS="-L${ROOT}/usr/$(get_libdir)"
+ export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')
+ -L${ROOT}/usr/$(get_libdir)"
# Setup GOPATH so things build
rm -rf .gopath