summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-07-10 20:14:06 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-07-10 22:10:49 -0400
commit1868dd11749c5bcb21533d69b4632b4a441b3d7c (patch)
tree31a70332fe89d3ec5387060a28c136a2381f360f /app-emulation/uade
parentapp-emulation/uade: add gitlab remote-id, re-indent (diff)
downloadgentoo-1868dd11749c5bcb21533d69b4632b4a441b3d7c.tar.gz
gentoo-1868dd11749c5bcb21533d69b4632b4a441b3d7c.tar.bz2
gentoo-1868dd11749c5bcb21533d69b4632b4a441b3d7c.zip
app-emulation/uade: tidy and fix VariableScope + fuse automagic
Adds IUSE=fuse to control building uadefs. Not doing major changes in stable, but also added EXTRA_ECONF should users want to change anything. src_install removed as it was only installing the man page a 2nd time. Closes: https://bugs.gentoo.org/608000 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation/uade')
-rw-r--r--app-emulation/uade/metadata.xml3
-rw-r--r--app-emulation/uade/uade-2.13-r2.ebuild52
2 files changed, 55 insertions, 0 deletions
diff --git a/app-emulation/uade/metadata.xml b/app-emulation/uade/metadata.xml
index 953db6df5415..c4c4b8d8413a 100644
--- a/app-emulation/uade/metadata.xml
+++ b/app-emulation/uade/metadata.xml
@@ -5,6 +5,9 @@
<email>games@gentoo.org</email>
<name>Gentoo Games Project</name>
</maintainer>
+ <use>
+ <flag name="fuse">Enable <pkg>sys-fs/fuse</pkg> uadefs frontend for on-the-fly WAV conversion</flag>
+ </use>
<upstream>
<remote-id type="gitlab">uade-music-player/uade</remote-id>
</upstream>
diff --git a/app-emulation/uade/uade-2.13-r2.ebuild b/app-emulation/uade/uade-2.13-r2.ebuild
new file mode 100644
index 000000000000..262a54d90331
--- /dev/null
+++ b/app-emulation/uade/uade-2.13-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Unix Amiga Delitracker Emulator - plays old Amiga tunes through UAE emulation"
+HOMEPAGE="https://zakalwe.fi/uade"
+SRC_URI="https://zakalwe.fi/uade/uade2/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="fuse"
+
+RDEPEND="
+ media-libs/libao
+ fuse? ( sys-fs/fuse:0 )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-configure.patch
+)
+
+DOCS=( AUTHORS ChangeLog doc/BUGS doc/PLANS )
+
+src_prepare() {
+ default
+
+ # needed to avoid ${D} VariableScope undefined behavior in src_configure
+ find . -name Makefile.in -exec sed -i 's|{PACKAGEPREFIX}|$(DESTDIR)|' {} + || die
+}
+
+src_configure() {
+ tc-export CC
+
+ # not autotools generated
+ local configure=(
+ ./configure
+ --prefix="${EPREFIX}"/usr
+ --libdir="${EPREFIX}"/usr/$(get_libdir)
+ --with-text-scope
+ --without-audacious
+ --without-xmms
+ $(use_with fuse uadefs)
+ ${EXTRA_ECONF}
+ )
+ echo ${configure[*]}
+ "${configure[@]}" || die
+}