summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <tmozes@sygic.com>2017-02-08 08:28:05 +0100
committerMichael Palimaka <kensington@gentoo.org>2017-02-11 22:33:44 +1100
commitf567303257d9f0d0db70b37f053ea65bb3af3ef8 (patch)
tree9861e44d5f31e0d256080825da71a28d52979365 /app-emulation/vagrant/vagrant-1.9.1-r1.ebuild
parentsys-auth/elogind: Drop old (diff)
downloadgentoo-f567303257d9f0d0db70b37f053ea65bb3af3ef8.tar.gz
gentoo-f567303257d9f0d0db70b37f053ea65bb3af3ef8.tar.bz2
gentoo-f567303257d9f0d0db70b37f053ea65bb3af3ef8.zip
app-emulation/vagrant: loosen dep on dev-ruby/childprocess
Gentoo-bug: 608522
Diffstat (limited to 'app-emulation/vagrant/vagrant-1.9.1-r1.ebuild')
-rw-r--r--app-emulation/vagrant/vagrant-1.9.1-r1.ebuild84
1 files changed, 84 insertions, 0 deletions
diff --git a/app-emulation/vagrant/vagrant-1.9.1-r1.ebuild b/app-emulation/vagrant/vagrant-1.9.1-r1.ebuild
new file mode 100644
index 000000000000..de188aa351a5
--- /dev/null
+++ b/app-emulation/vagrant/vagrant-1.9.1-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
+RUBY_FAKEGEM_EXTRAINSTALL="keys plugins templates version.txt"
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit bash-completion-r1 ruby-fakegem eutils
+
+DESCRIPTION="A tool for building and distributing development environments"
+HOMEPAGE="http://vagrantup.com/"
+SRC_URI="https://github.com/mitchellh/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+virtualbox"
+
+RDEPEND="${RDEPEND}
+ app-arch/libarchive
+ net-misc/curl
+ virtualbox? ( || ( app-emulation/virtualbox app-emulation/virtualbox-bin ) )"
+
+ruby_add_rdepend "
+ >=dev-ruby/childprocess-0.5.0
+ >=dev-ruby/erubis-2.7.0
+ >=dev-ruby/i18n-0.6.0:* <dev-ruby/i18n-0.8.0:*
+ >=dev-ruby/listen-3.1.5
+ >=dev-ruby/hashicorp-checkpoint-0.1.1
+ >=dev-ruby/log4r-1.1.9 <dev-ruby/log4r-1.1.11
+ >=dev-ruby/net-ssh-3.0.1
+ >=dev-ruby/net-sftp-2.1
+ >=dev-ruby/net-scp-1.1.0
+ || ( >=dev-ruby/rest-client-1.6.0:0 dev-ruby/rest-client:2 )
+ >=dev-ruby/nokogiri-1.6.7.1
+ >=dev-ruby/mime-types-2.6.2:* <dev-ruby/mime-types-3:*
+"
+
+ruby_add_bdepend "
+ >=dev-ruby/rake-11.3.0
+"
+
+all_ruby_prepare() {
+ # remove bundler support
+ sed -i '/[Bb]undler/d' Rakefile || die
+ rm Gemfile || die
+
+ # loosen dependencies
+ sed -e '/hashicorp-checkpoint\|listen\|net-ssh\|net-scp\|rake\|childprocess/s/~>/>=/' \
+ -e '/ruby_dep/s/<=/>=/' \
+ -e '/nokogiri/s/=/>=/' \
+ -i ${PN}.gemspec || die
+
+ # remove windows-specific gems
+ sed -e '/wdm\|winrm/d' \
+ -i ${PN}.gemspec || die
+
+ # remove bsd-specific gems
+ sed -e '/rb-kqueue/d' \
+ -i ${PN}.gemspec || die
+
+ # disable embedded CA certs and use system ones
+ epatch "${FILESDIR}"/${PN}-1.8.1-disable-embedded-cacert.patch
+
+ # fix rvm issue (bug #474476)
+ epatch "${FILESDIR}"/${PN}-1.8.1-rvm.patch
+}
+
+all_ruby_install() {
+ newbashcomp contrib/bash/completion.sh ${PN}
+ all_fakegem_install
+
+ # provide executable similar to upstream:
+ # https://github.com/mitchellh/vagrant-installers/blob/master/substrate/modules/vagrant_installer/templates/vagrant.erb
+ newbin "${FILESDIR}/${P}" "${PN}"
+
+ # directory for plugins.json
+ dodir /var/lib/vagrant
+}