summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-12-17 12:15:35 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2015-12-17 19:38:20 -0500
commit0709f2aa4c0aae2816558c3a9230a97fc4a3a673 (patch)
tree2a7df3a3977cd3b5cf431783e5b7783d7e5140b3 /app-emulation/vice/files
parentclean old (diff)
downloadgentoo-0709f2aa4c0aae2816558c3a9230a97fc4a3a673.tar.gz
gentoo-0709f2aa4c0aae2816558c3a9230a97fc4a3a673.tar.bz2
gentoo-0709f2aa4c0aae2816558c3a9230a97fc4a3a673.zip
clean old
Package-Manager: portage-2.2.24
Diffstat (limited to 'app-emulation/vice/files')
-rw-r--r--app-emulation/vice/files/vice-2.4-arm.patch38
-rw-r--r--app-emulation/vice/files/vice-2.4-autotools.patch11
-rw-r--r--app-emulation/vice/files/vice-2.4-buffer.patch14
-rw-r--r--app-emulation/vice/files/vice-2.4-ffmpeg-1.patch135
4 files changed, 0 insertions, 198 deletions
diff --git a/app-emulation/vice/files/vice-2.4-arm.patch b/app-emulation/vice/files/vice-2.4-arm.patch
deleted file mode 100644
index 55e2d5a35b0c..000000000000
--- a/app-emulation/vice/files/vice-2.4-arm.patch
+++ /dev/null
@@ -1,38 +0,0 @@
---- vice/configure.in
-+++ vice/configure.in
-@@ -2299,6 +2299,7 @@
-
- if test x"$PARSID_SUPPORT" = "xno"; then
- AC_CHECK_FUNCS(ioperm,[PARSID_SUPPORT=yes],)
-+ AC_CHECK_FUNCS(outb_p inb_p)
- fi
-
- if test x"$PARSID_SUPPORT" = "xyes"; then
---- vice/src/arch/unix/parsid.c
-+++ vice/src/arch/unix/parsid.c
-@@ -217,8 +217,12 @@
- #endif
- #endif
- #ifdef HAVE_IOPERM
-+#ifndef HAVE_OUTB_P
-+ outb(value, addr);
-+#else
- outb_p(value, addr);
- #endif
-+#endif
- }
-
- BYTE parsid_inb(int addr)
-@@ -237,8 +241,12 @@
- #endif
- #endif
- #ifdef HAVE_IOPERM
-+#ifndef HAVE_INB_P
-+ return inb((unsigned short)addr);
-+#else
- return inb_p((unsigned short)addr);
- #endif
-+#endif
- }
-
- /* chip control pin assignments */
diff --git a/app-emulation/vice/files/vice-2.4-autotools.patch b/app-emulation/vice/files/vice-2.4-autotools.patch
deleted file mode 100644
index f67113f0b45e..000000000000
--- a/app-emulation/vice/files/vice-2.4-autotools.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- vice-2.4.orig/configure.in
-+++ vice-2.4/configure.in
-@@ -105,7 +105,7 @@
- AC_SUBST(VICE_VERSION)
-
- AM_INIT_AUTOMAKE(vice, $VICE_VERSION)
--AM_CONFIG_HEADER(src/config.h)
-+AC_CONFIG_HEADERS(src/config.h)
-
- if test x"$VICE_VERSION_BUILD" = "x" -o x"$VICE_VERSION_BUILD" = "x0" ; then
- VERSION_RC=$VICE_VERSION_MAJOR","$VICE_VERSION_MINOR",0,0"
diff --git a/app-emulation/vice/files/vice-2.4-buffer.patch b/app-emulation/vice/files/vice-2.4-buffer.patch
deleted file mode 100644
index dc5fab9b5725..000000000000
--- a/app-emulation/vice/files/vice-2.4-buffer.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-avoid writing past the end of the gcr_track buffer
-https://bugs.gentoo.org/show_bug.cgi?id=464708
-
---- ./src/diskimage/fsimage-create.c.orig
-+++ ./src/diskimage/fsimage-create.c
-@@ -262,7 +262,7 @@
- gcrptr = gcr_track;
- util_word_to_le_buf(gcrptr, disk_image_raw_track_size(image->type, track));
- gcrptr += 2;
-- memset(gcrptr, 0x55, NUM_MAX_BYTES_TRACK);
-+ memset(gcrptr, 0x55, NUM_MAX_BYTES_TRACK - 2);
-
- header.track = track;
- for (sector = 0;
diff --git a/app-emulation/vice/files/vice-2.4-ffmpeg-1.patch b/app-emulation/vice/files/vice-2.4-ffmpeg-1.patch
deleted file mode 100644
index 4aefda24584f..000000000000
--- a/app-emulation/vice/files/vice-2.4-ffmpeg-1.patch
+++ /dev/null
@@ -1,135 +0,0 @@
-Fixes build with recent FFmpeg versions.
-
-https://bugs.gentoo.org/show_bug.cgi?id=443218
-https://sourceforge.net/tracker/?func=detail&aid=3601992&group_id=223021&atid=1057619
-
---- vice-2.4.orig/src/gfxoutputdrv/ffmpegdrv.c
-+++ vice-2.4/src/gfxoutputdrv/ffmpegdrv.c
-@@ -343,7 +343,7 @@ static int ffmpegmovie_init_audio(int sp
- c = st->codec;
- c->codec_id = ffmpegdrv_fmt->audio_codec;
- c->codec_type = AVMEDIA_TYPE_AUDIO;
-- c->sample_fmt = SAMPLE_FMT_S16;
-+ c->sample_fmt = AV_SAMPLE_FMT_S16;
-
- /* put sample parameters */
- c->bit_rate = audio_bitrate;
-@@ -613,12 +613,7 @@ static int ffmpegdrv_init_file(void)
- if (!video_init_done || !audio_init_done)
- return 0;
-
-- if ((*ffmpeglib.p_av_set_parameters)(ffmpegdrv_oc, NULL) < 0) {
-- log_debug("ffmpegdrv: Invalid output format parameters");
-- return -1;
-- }
--
-- (*ffmpeglib.p_dump_format)(ffmpegdrv_oc, 0, ffmpegdrv_oc->filename, 1);
-+ (*ffmpeglib.p_av_dump_format)(ffmpegdrv_oc, 0, ffmpegdrv_oc->filename, 1);
-
- if (video_st && (ffmpegdrv_open_video(ffmpegdrv_oc, video_st) < 0)) {
- ui_error(translate_text(IDGS_FFMPEG_CANNOT_OPEN_VSTREAM));
-@@ -632,8 +627,8 @@ static int ffmpegdrv_init_file(void)
- }
-
- if (!(ffmpegdrv_fmt->flags & AVFMT_NOFILE)) {
-- if ((*ffmpeglib.p_url_fopen)(&ffmpegdrv_oc->pb, ffmpegdrv_oc->filename,
-- URL_WRONLY) < 0)
-+ if ((*ffmpeglib.p_avio_open)(&ffmpegdrv_oc->pb, ffmpegdrv_oc->filename,
-+ AVIO_FLAG_WRITE) < 0)
- {
- ui_error(translate_text(IDGS_FFMPEG_CANNOT_OPEN_S), ffmpegdrv_oc->filename);
- screenshot_stop_recording();
-@@ -642,7 +637,7 @@ static int ffmpegdrv_init_file(void)
-
- }
-
-- (*ffmpeglib.p_av_write_header)(ffmpegdrv_oc);
-+ (*ffmpeglib.p_avformat_write_header)(ffmpegdrv_oc,NULL);
-
- log_debug("ffmpegdrv: Initialized file successfully");
-
-@@ -724,7 +719,7 @@ static int ffmpegdrv_close(screenshot_t
- (*ffmpeglib.p_av_write_trailer)(ffmpegdrv_oc);
- if (!(ffmpegdrv_fmt->flags & AVFMT_NOFILE)) {
- /* close the output file */
-- (*ffmpeglib.p_url_fclose)(ffmpegdrv_oc->pb);
-+ (*ffmpeglib.p_avio_close)(ffmpegdrv_oc->pb);
- }
- }
-
---- vice-2.4.orig/src/gfxoutputdrv/ffmpeglib.c
-+++ vice-2.4/src/gfxoutputdrv/ffmpeglib.c
-@@ -208,13 +208,12 @@ static int load_avformat(ffmpeglib_t *li
- GET_SYMBOL_AND_TEST_AVFORMAT(av_init_packet);
- GET_SYMBOL_AND_TEST_AVFORMAT(av_register_all);
- GET_SYMBOL_AND_TEST_AVFORMAT(av_new_stream);
-- GET_SYMBOL_AND_TEST_AVFORMAT(av_set_parameters);
-- GET_SYMBOL_AND_TEST_AVFORMAT(av_write_header);
-+ GET_SYMBOL_AND_TEST_AVFORMAT(avformat_write_header);
- GET_SYMBOL_AND_TEST_AVFORMAT(av_write_frame);
- GET_SYMBOL_AND_TEST_AVFORMAT(av_write_trailer);
-- GET_SYMBOL_AND_TEST_AVFORMAT(url_fopen);
-- GET_SYMBOL_AND_TEST_AVFORMAT(url_fclose);
-- GET_SYMBOL_AND_TEST_AVFORMAT(dump_format);
-+ GET_SYMBOL_AND_TEST_AVFORMAT(avio_open);
-+ GET_SYMBOL_AND_TEST_AVFORMAT(avio_close);
-+ GET_SYMBOL_AND_TEST_AVFORMAT(av_dump_format);
- GET_SYMBOL_AND_TEST_AVFORMAT(av_guess_format);
- #ifndef HAVE_FFMPEG_SWSCALE
- GET_SYMBOL_AND_TEST_AVFORMAT(img_convert);
-@@ -240,13 +239,12 @@ static void free_avformat(ffmpeglib_t *l
- lib->p_av_init_packet = NULL;
- lib->p_av_register_all = NULL;
- lib->p_av_new_stream = NULL;
-- lib->p_av_set_parameters = NULL;
-- lib->p_av_write_header = NULL;
-+ lib->p_avformat_write_header = NULL;
- lib->p_av_write_frame = NULL;
- lib->p_av_write_trailer = NULL;
-- lib->p_url_fopen = NULL;
-- lib->p_url_fclose = NULL;
-- lib->p_dump_format = NULL;
-+ lib->p_avio_open = NULL;
-+ lib->p_avio_close = NULL;
-+ lib->p_av_dump_format = NULL;
- lib->p_av_guess_format = NULL;
- #ifndef HAVE_FFMPEG_SWSCALE
- lib->p_img_convert = NULL;
---- vice-2.4.orig/src/gfxoutputdrv/ffmpeglib.h
-+++ vice-2.4/src/gfxoutputdrv/ffmpeglib.h
-@@ -80,13 +80,12 @@ typedef int (*avpicture_get_size_t) (int
- typedef void (*av_init_packet_t) (AVPacket *pkt);
- typedef void (*av_register_all_t) (void);
- typedef AVStream* (*av_new_stream_t) (AVFormatContext*, int);
--typedef int (*av_set_parameters_t) (AVFormatContext*, AVFormatParameters*);
--typedef int (*av_write_header_t) (AVFormatContext*);
-+typedef int (*avformat_write_header_t) (AVFormatContext*,AVDictionary **);
- typedef int (*av_write_frame_t) (AVFormatContext*, AVPacket*);
- typedef int (*av_write_trailer_t) (AVFormatContext*);
--typedef int (*url_fopen_t) (ByteIOContext**, const char*, int);
--typedef int (*url_fclose_t) (ByteIOContext*);
--typedef void (*dump_format_t) (AVFormatContext *, int, const char*, int);
-+typedef int (*avio_open_t) (AVIOContext**, const char*, int);
-+typedef int (*avio_close_t) (AVIOContext*);
-+typedef void (*av_dump_format_t) (AVFormatContext *, int, const char*, int);
- typedef AVOutputFormat* (*av_guess_format_t) (const char*, const char*, const char*);
- typedef int (*img_convert_t) (AVPicture*, int, AVPicture*, int, int, int);
-
-@@ -118,13 +117,12 @@ struct ffmpeglib_s {
- av_init_packet_t p_av_init_packet;
- av_register_all_t p_av_register_all;
- av_new_stream_t p_av_new_stream;
-- av_set_parameters_t p_av_set_parameters;
-- av_write_header_t p_av_write_header;
-+ avformat_write_header_t p_avformat_write_header;
- av_write_frame_t p_av_write_frame;
- av_write_trailer_t p_av_write_trailer;
-- url_fopen_t p_url_fopen;
-- url_fclose_t p_url_fclose;
-- dump_format_t p_dump_format;
-+ avio_open_t p_avio_open;
-+ avio_close_t p_avio_close;
-+ av_dump_format_t p_av_dump_format;
- av_guess_format_t p_av_guess_format;
- #ifndef HAVE_FFMPEG_SWSCALE
- img_convert_t p_img_convert;