summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-11-11 23:06:55 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2015-11-11 23:06:55 -0500
commit79181c4192325a722f4c01aa987e152e1efbff96 (patch)
tree62a3cdd046f3fddb8ce5e0a257dc5df845590e04 /app-emulation/vice/files
parentnet-mail/mailshears: new package mailshears, mangle your mail garden. (diff)
downloadgentoo-79181c4192325a722f4c01aa987e152e1efbff96.tar.gz
gentoo-79181c4192325a722f4c01aa987e152e1efbff96.tar.bz2
gentoo-79181c4192325a722f4c01aa987e152e1efbff96.zip
restore mistakenly removed stable ebuild (bug #565442)
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'app-emulation/vice/files')
-rw-r--r--app-emulation/vice/files/vice-2.4.20-autotools.patch11
-rw-r--r--app-emulation/vice/files/vice-2.4.20-format.patch20
-rw-r--r--app-emulation/vice/files/vice-2.4.20-xf86extensions.patch15
3 files changed, 46 insertions, 0 deletions
diff --git a/app-emulation/vice/files/vice-2.4.20-autotools.patch b/app-emulation/vice/files/vice-2.4.20-autotools.patch
new file mode 100644
index 000000000000..7bebd2800ef6
--- /dev/null
+++ b/app-emulation/vice/files/vice-2.4.20-autotools.patch
@@ -0,0 +1,11 @@
+--- vice-2.4.7.orig/configure.ac
++++ vice-2.4.7/configure.ac
+@@ -124,7 +118,7 @@
+ AC_SUBST(VICE_VERSION)
+
+ AM_INIT_AUTOMAKE(vice, $VICE_VERSION)
+-AM_CONFIG_HEADER(src/config.h)
++AC_CONFIG_HEADERS(src/config.h)
+
+ if test x"$VICE_VERSION_BUILD" = "x" -o x"$VICE_VERSION_BUILD" = "x0" ; then
+ VERSION_RC=$VICE_VERSION_MAJOR","$VICE_VERSION_MINOR",0,0"
diff --git a/app-emulation/vice/files/vice-2.4.20-format.patch b/app-emulation/vice/files/vice-2.4.20-format.patch
new file mode 100644
index 000000000000..1c782fd61e5d
--- /dev/null
+++ b/app-emulation/vice/files/vice-2.4.20-format.patch
@@ -0,0 +1,20 @@
+--- src/main.c.old 2015-10-19 17:25:07.549164652 +0200
++++ src/main.c 2015-10-19 17:25:33.106694706 +0200
+@@ -227,7 +227,7 @@
+ for (i = 0; core_team[i].name; i++) {
+ n += strlen(core_team[i].name);
+ if (n > 74) {
+- log_message(LOG_DEFAULT, tmp);
++ log_message(LOG_DEFAULT, "%s", tmp);
+ n = 0; *tmp = 0;
+ }
+ strcat(tmp, core_team[i].name);
+@@ -235,7 +235,7 @@
+ strcat(tmp, ", ");
+ } else {
+ strcat(tmp, ".");
+- log_message(LOG_DEFAULT, tmp);
++ log_message(LOG_DEFAULT, "%s", tmp);
+ }
+ }
+ lib_free(tmp);
diff --git a/app-emulation/vice/files/vice-2.4.20-xf86extensions.patch b/app-emulation/vice/files/vice-2.4.20-xf86extensions.patch
new file mode 100644
index 000000000000..357d68666511
--- /dev/null
+++ b/app-emulation/vice/files/vice-2.4.20-xf86extensions.patch
@@ -0,0 +1,15 @@
+--- a/trunk/vice/src/arch/unix/x11/gnome/x11ui.c
++++ b/trunk/vice/src/arch/unix/x11/gnome/x11ui.c
+@@ -102,9 +102,10 @@
+ #include "ui-threads.h"
+ #endif
+
+-#ifdef USE_XF86_EXTENSIONS
++#if defined(USE_XF86_EXTENSIONS) || !defined(HAVE_VTE)
+ #include <gdk/gdkx.h>
+ #endif
++
+ #include "x11ui.h"
+
+ #ifdef DEBUG_X11UI
+