summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emulation/vmware-tools/vmware-tools-9.6.1.1379776.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emulation/vmware-tools/vmware-tools-9.6.1.1379776.ebuild')
-rw-r--r--app-emulation/vmware-tools/vmware-tools-9.6.1.1379776.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-emulation/vmware-tools/vmware-tools-9.6.1.1379776.ebuild b/app-emulation/vmware-tools/vmware-tools-9.6.1.1379776.ebuild
new file mode 100644
index 000000000000..b3a29af4d322
--- /dev/null
+++ b/app-emulation/vmware-tools/vmware-tools-9.6.1.1379776.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit versionator vmware-bundle
+
+MY_PV="$(replace_version_separator 3 - $PV)"
+BASE_URI="http://softwareupdate.vmware.com/cds/vmw-desktop/player/6.0.$(get_version_component_range 3)/$(get_version_component_range 4)/linux/packages/"
+
+DESCRIPTION="VMware Tools for guest operating systems"
+HOMEPAGE="http://www.vmware.com/products/player/"
+
+LICENSE="vmware"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="mirror"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+IUSE_VMWARE_GUEST="freebsd linux netware solaris windows winPre2k"
+
+VM_INSTALL_DIR="/opt/vmware"
+
+for guest in ${IUSE_VMWARE_GUEST} ; do
+ SRC_URI+=" vmware_guest_${guest}? (
+ amd64? ( ${BASE_URI}vmware-tools-${guest}-${MY_PV}.x86_64.component.tar )
+ x86? ( ${BASE_URI}vmware-tools-${guest}-${MY_PV}.i386.component.tar )
+ )"
+ IUSE+=" vmware_guest_${guest}"
+done ; unset guest
+
+src_unpack() {
+ local arch
+ if use x86 ; then arch='i386'
+ elif use amd64 ; then arch='x86_64'
+ fi
+ local guest ; for guest in ${IUSE_VMWARE_GUEST} ; do
+ if use "vmware_guest_${guest}" ; then
+ local component="vmware-tools-${guest}-${MY_PV}.${arch}.component"
+ unpack "${component}.tar"
+ vmware-bundle_extract-component "${component}"
+ fi
+ done
+}
+
+src_install() {
+ insinto "${VM_INSTALL_DIR}"/lib/vmware/isoimages
+ local guest ; for guest in ${IUSE_VMWARE_GUEST} ; do
+ if use "vmware_guest_${guest}" ; then
+ doins "${guest}".iso{,.sig}
+ fi
+ done
+}