summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2017-04-10 12:52:28 -0400
committerNP-Hardass <NP-Hardass@gentoo.org>2017-04-10 13:21:50 -0400
commitae60dc775127b8a8bca851b95eba847e4d6f7f9f (patch)
treeb7a7a48dc9b0174e70f03b778e05b089e277f697 /app-emulation/wine-desktop-common/wine-desktop-common-20150204.ebuild
parentapp-eselect/eselect-wine: Eselect module for slotted/split wine (diff)
downloadgentoo-ae60dc775127b8a8bca851b95eba847e4d6f7f9f.tar.gz
gentoo-ae60dc775127b8a8bca851b95eba847e4d6f7f9f.tar.bz2
gentoo-ae60dc775127b8a8bca851b95eba847e4d6f7f9f.zip
app-emulation/wine-desktop-common: Shared files between variants/slots
Imported from wine-a-holics overlay Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-emulation/wine-desktop-common/wine-desktop-common-20150204.ebuild')
-rw-r--r--app-emulation/wine-desktop-common/wine-desktop-common-20150204.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-emulation/wine-desktop-common/wine-desktop-common-20150204.ebuild b/app-emulation/wine-desktop-common/wine-desktop-common-20150204.ebuild
new file mode 100644
index 000000000000..b5131486decd
--- /dev/null
+++ b/app-emulation/wine-desktop-common/wine-desktop-common-20150204.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit gnome2-utils
+
+DESCRIPTION="Various desktop menu items and icons for wine"
+HOMEPAGE="https://github.com/NP-Hardass/wine-desktop-common
+ http://dev.gentoo.org/~tetromino/distfiles/wine
+ http://bazaar.launchpad.net/~ubuntu-wine/wine/ubuntu-debian-dir/files/head:/debian/"
+SRC_URI="http://github.com/NP-Hardass/${PN}/archive/${PV//./}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="!!app-emulation/wine:0"
+PDEPEND="app-eselect/eselect-wine"
+
+# These use a non-standard "Wine" category, which is provided by
+# /etc/xdg/applications-merged/wine.menu
+QA_DESKTOP_FILE="usr/share/applications/wine-browsedrive.desktop
+usr/share/applications/wine-notepad.desktop
+usr/share/applications/wine-uninstaller.desktop
+usr/share/applications/wine-winecfg.desktop"
+
+S=${WORKDIR}/${PN}-${PV//./}
+
+src_install() {
+ emake install DESTDIR="${D}" EPREFIX="${EPREFIX}"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}