summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-08-11 02:23:49 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-08-11 06:00:06 -0400
commit9ce91430dd2d8e4f57c8b6366d0aa810c0d90cb8 (patch)
tree327158e92ce5608f8973da626fbe9e10be3216e4 /app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
parentdev-python/pydantic-core: Disable implicit stripping (diff)
downloadgentoo-9ce91430dd2d8e4f57c8b6366d0aa810c0d90cb8.tar.gz
gentoo-9ce91430dd2d8e4f57c8b6366d0aa810c0d90cb8.tar.bz2
gentoo-9ce91430dd2d8e4f57c8b6366d0aa810c0d90cb8.zip
app-emulation/wine-vanilla: fix build with clang:17
Was silently ignored with <clang-16, but clang:17 now considers this an error. Working -mabi=ms is required with USE=-mingw, but with USE=mingw seems it gets used in install phase possibly(?) by mistake. As a quick fix, drop the option for now. Prefer to leave alone for gcc, so done in ebuild w/ tc-is-clang. Also add an early abort for USE=-mingw while here, this was always failing due to missing -mabi=ms even with older clang. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation/wine-vanilla/wine-vanilla-9999.ebuild')
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-9999.ebuild12
1 files changed, 12 insertions, 0 deletions
diff --git a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
index 9f0672c16b6e..dbe3af0eae78 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
@@ -181,6 +181,18 @@ src_prepare() {
default
+ if tc-is-clang; then
+ if use mingw; then
+ # -mabi=ms was ignored by <clang:16 then turned error in :17
+ # and it still gets used in install phase despite USE=mingw,
+ # drop as a quick fix for now which hopefully should be safe
+ sed -i '/MSVCRTFLAGS=/s/-mabi=ms//' configure.ac || die
+ else
+ # ./configure will abort looking for -mabi=ms, so do it early
+ die "building ${PN} with clang requires USE=mingw to be enabled"
+ fi
+ fi
+
# ensure .desktop calls this variant + slot
sed -i "/^Exec=/s/wine /${P} /" loader/wine.desktop || die