summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-02-16 05:23:30 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-02-16 05:50:44 -0500
commitcc304cc97db031a866c899634b40055f4116307b (patch)
treead7fc257cd3f22df593a7d8158be56267a9ad9e0 /app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
parentnet-proxy/haproxy: Bump to 2.8.6 (diff)
downloadgentoo-cc304cc97db031a866c899634b40055f4116307b.tar.gz
gentoo-cc304cc97db031a866c899634b40055f4116307b.tar.bz2
gentoo-cc304cc97db031a866c899634b40055f4116307b.zip
app-emulation/wine-vanilla: optfeature on game-device-udev-rules
In 9.1+, wine defaults to using /dev/hidraw* for some extra gamepads, most notably Sony DualShock4 which may come as unexpected. /dev/hidraw* access is restricted to root by default leaving users with a situation that seem like a wine regression. Only a optfeature since most gamepads do not need this (xbox one, about any 3rd party gamepads, etc...). Hopefully the optfeature is noticed by affected users. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation/wine-vanilla/wine-vanilla-9999.ebuild')
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-9999.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
index cf08e9f83489..f9fd23e3c79a 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=8
MULTILIB_COMPAT=( abi_x86_{32,64} )
-inherit autotools flag-o-matic multilib multilib-build
+inherit autotools flag-o-matic optfeature multilib multilib-build
inherit prefix toolchain-funcs wrapper
WINE_GECKO=2.47.4
@@ -415,6 +415,9 @@ pkg_postinst() {
ewarn "applications under ${PN} will likely not be usable."
fi
+ optfeature "/dev/hidraw* access used for *some* controllers (e.g. DualShock4)" \
+ games-util/game-device-udev-rules
+
eselect wine update --if-unset || die
}