summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2017-03-12 17:26:04 -0400
committerNP-Hardass <NP-Hardass@gentoo.org>2017-03-12 17:26:33 -0400
commit5829502de752852949c11138e6a472a7a043ee58 (patch)
tree7ba2293f029eb396065b0fe10f27bd9e607c0446 /app-emulation/wine/wine-2.0.ebuild
parentgames-puzzle/sgt-puzzles: Bump to 20170228, #602696 (diff)
downloadgentoo-5829502de752852949c11138e6a472a7a043ee58.tar.gz
gentoo-5829502de752852949c11138e6a472a7a043ee58.tar.bz2
gentoo-5829502de752852949c11138e6a472a7a043ee58.zip
app-emulation/wine: move compilation checks to src_configure, #610752
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-emulation/wine/wine-2.0.ebuild')
-rw-r--r--app-emulation/wine/wine-2.0.ebuild18
1 files changed, 17 insertions, 1 deletions
diff --git a/app-emulation/wine/wine-2.0.ebuild b/app-emulation/wine/wine-2.0.ebuild
index a5e69c16bff3..e037d416acfa 100644
--- a/app-emulation/wine/wine-2.0.ebuild
+++ b/app-emulation/wine/wine-2.0.ebuild
@@ -199,6 +199,21 @@ wine_compiler_check() {
wine_build_environment_check() {
[[ ${MERGE_TYPE} = "binary" ]] && return 0
+ if use abi_x86_64; then
+ if tc-is-gcc && [[ $(gcc-major-version) -lt 4 || ( $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 4 ) ]]; then
+ eerror "You need gcc-4.4+ to compile 64-bit wine"
+ die
+ elif tc-is-clang && [[ $(clang-major-version) -lt 3 || ( $(clang-major-version) -eq 3 && $(clang-minor-version) -lt 8 ) ]]; then
+ eerror "You need clang-3.8+ to compile 64-bit wine"
+ die
+ fi
+ fi
+ if tc-is-gcc && [[ $(gcc-major-version) -eq 5 && $(gcc-minor-version) -le 3 ]]; then
+ ewarn "GCC-5.0-5.3 suffered from compiler bugs and are no longer supported by"
+ ewarn "Gentoo's Toolchain Team. If your ebuild fails the compiler checks in"
+ ewarn "the configure phase, either update your compiler or switch to <5.0 || >=5.4"
+ fi
+
if use abi_x86_32 && use opencl && [[ "$(eselect opencl show 2> /dev/null)" == "intel" ]]; then
eerror "You cannot build wine with USE=opencl because intel-ocl-sdk is 64-bit only."
eerror "See https://bugs.gentoo.org/487864 for more details."
@@ -208,7 +223,6 @@ wine_build_environment_check() {
}
pkg_pretend() {
- wine_compiler_check || die
wine_build_environment_check || die
# Verify OSS support
@@ -270,6 +284,8 @@ src_prepare() {
}
src_configure() {
+ wine_compiler_check || die
+
export LDCONFIG=/bin/true
use custom-cflags || strip-flags