summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-03-05 21:54:55 -0500
committerNP-Hardass <NP-Hardass@gentoo.org>2016-03-05 21:56:58 -0500
commitffba11ee1a2fe07e65c8ada2531e953ac3239fb5 (patch)
tree8b3d9b89f95331c35e24d440d02c39689387b96a /app-emulation/wine/wine-9999.ebuild
parentapp-emulation/wine: Version bump to 1.9.4, now uses gstreamer 1.0 (diff)
downloadgentoo-ffba11ee1a2fe07e65c8ada2531e953ac3239fb5.tar.gz
gentoo-ffba11ee1a2fe07e65c8ada2531e953ac3239fb5.tar.bz2
gentoo-ffba11ee1a2fe07e65c8ada2531e953ac3239fb5.zip
app-emulation/wine: Update 9999, bump mono, fix bug #576360
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-emulation/wine/wine-9999.ebuild')
-rw-r--r--app-emulation/wine/wine-9999.ebuild34
1 files changed, 5 insertions, 29 deletions
diff --git a/app-emulation/wine/wine-9999.ebuild b/app-emulation/wine/wine-9999.ebuild
index b44030bba0e6..2c75d7b61190 100644
--- a/app-emulation/wine/wine-9999.ebuild
+++ b/app-emulation/wine/wine-9999.ebuild
@@ -22,12 +22,11 @@ else
KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
fi
-GV="2.40"
-MV="4.5.6"
+GV="2.44"
+MV="4.6.0"
STAGING_P="wine-staging-${PV}"
STAGING_DIR="${WORKDIR}/${STAGING_P}"
WINE_GENTOO="wine-gentoo-2015.03.07"
-GST_P="wine-1.7.55-gstreamer-v5"
DESCRIPTION="Free implementation of Windows(tm) on Unix"
HOMEPAGE="http://www.winehq.org/"
SRC_URI="${SRC_URI}
@@ -36,7 +35,6 @@ SRC_URI="${SRC_URI}
abi_x86_64? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86_64.msi )
)
mono? ( https://dl.winehq.org/wine/wine-mono/${MV}/wine-mono-${MV}.msi )
- gstreamer? ( https://dev.gentoo.org/~np-hardass/distfiles/${PN}/${GST_P}.patch.bz2 )
https://dev.gentoo.org/~tetromino/distfiles/${PN}/${WINE_GENTOO}.tar.bz2"
if [[ ${PV} == "9999" ]] ; then
@@ -57,7 +55,6 @@ REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )
s3tc? ( staging )
vaapi? ( staging )
osmesa? ( opengl )" #286560
- #?? ( gstreamer staging ) #Should be fixed by pre/post patchset
# FIXME: the test suite is unsuitable for us; many tests require net access
# or fail due to Xvfb's opengl limitations.
@@ -72,8 +69,8 @@ COMMON_DEPEND="
gphoto2? ( media-libs/libgphoto2:=[${MULTILIB_USEDEP}] )
openal? ( media-libs/openal:=[${MULTILIB_USEDEP}] )
gstreamer? (
- media-libs/gstreamer:0.10[${MULTILIB_USEDEP}]
- media-libs/gst-plugins-base:0.10[${MULTILIB_USEDEP}]
+ media-libs/gstreamer:1.0[${MULTILIB_USEDEP}]
+ media-plugins/gst-plugins-meta:1.0[${MULTILIB_USEDEP}]
)
X? (
x11-libs/libXcursor[${MULTILIB_USEDEP}]
@@ -226,7 +223,6 @@ src_unpack() {
fi
unpack "${WINE_GENTOO}.tar.bz2"
- use gstreamer && unpack "${GST_P}.patch.bz2"
l10n_find_plocales_changes "${S}/po" "" ".po"
}
@@ -235,30 +231,10 @@ src_prepare() {
local md5="$(md5sum server/protocol.def)"
local PATCHES=(
"${FILESDIR}"/${PN}-1.5.26-winegcc.patch #260726
- "${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
+ "${FILESDIR}"/${PN}-1.9.5-multilib-portage.patch #395615
"${FILESDIR}"/${PN}-1.7.12-osmesa-check.patch #429386
"${FILESDIR}"/${PN}-1.6-memset-O3.patch #480508
)
- if use gstreamer; then
- # See http://bugs.winehq.org/show_bug.cgi?id=30557
- ewarn "Applying experimental patch to fix GStreamer support. Note that"
- ewarn "this patch has been reported to cause crashes in certain games."
-
- # Wine-Staging 1.7.38 "ntdll: Fix race-condition when threads are killed
- # during shutdown" patch and "Added patch to implement shared memory
- # wineserver communication for various user32 functions" prevents the
- # gstreamer patch from applying cleanly.
- # So undo the staging patch, apply gstreamer, then re-apply rebased staging
- # patch on top.
- if use staging; then
- PATCHES+=(
- "${FILESDIR}/${PN}-1.7.55-gstreamer-v5-staging-pre.patch"
- "${WORKDIR}/${GST_P}.patch"
- "${FILESDIR}/${PN}-1.7.55-gstreamer-v5-staging-post.patch" )
- else
- PATCHES+=( "${WORKDIR}/${GST_P}.patch" )
- fi
- fi
if use staging; then
ewarn "Applying the Wine-Staging patchset. Any bug reports to the"
ewarn "Wine bugzilla should explicitly state that staging was used."