summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2015-11-16 21:10:40 -0500
committerNP-Hardass <NP-Hardass@gentoo.org>2015-11-16 21:12:26 -0500
commita8c7511988a20e4b236cb0719f1cc41a692f5cb5 (patch)
treee118c58372b8d14d4cae9d7cf35f6cb101b0b144 /app-emulation/winetricks
parentsys-kernel/git-sources: Versionbump to 4.4, remove 4.3 (diff)
downloadgentoo-a8c7511988a20e4b236cb0719f1cc41a692f5cb5.tar.gz
gentoo-a8c7511988a20e4b236cb0719f1cc41a692f5cb5.tar.bz2
gentoo-a8c7511988a20e4b236cb0719f1cc41a692f5cb5.zip
app-emulation/winetricks: Version bump to 20151116 to support pulse
Package-Manager: portage-2.2.23
Diffstat (limited to 'app-emulation/winetricks')
-rw-r--r--app-emulation/winetricks/Manifest1
-rw-r--r--app-emulation/winetricks/winetricks-20151116.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/app-emulation/winetricks/Manifest b/app-emulation/winetricks/Manifest
index e2e066e1f611..eb44effef09e 100644
--- a/app-emulation/winetricks/Manifest
+++ b/app-emulation/winetricks/Manifest
@@ -1,2 +1,3 @@
DIST winetricks-20151110.tar.gz 174736 SHA256 788662ddf6177893db3c1ced11be91982ceaf1d714fef94bc1e966c812420782 SHA512 ba77b055c956c03cb36c0eb47430f1273ce2e8a11e8f80cd3e5968bc2abfc1de9a6d5498f6e4253b538a315b7aa7fa138d1d92f561aad52794fbe6b04d20ad61 WHIRLPOOL 78db58e5bd7873e75c8a76636351d993f9d47d8144a6ff657136972774e9d0d52382c1ebe113ba643a9e204bec03a29efa275b719c817f4f9e9c16aaa2f8e961
+DIST winetricks-20151116.tar.gz 174763 SHA256 a8947974f47ec575e62717abe591a737d7214557e7ece4c39de079599ba4bf70 SHA512 a769eefcc80725b871791dbec9b869bdfdbbbccf816b943a242ee17f3a35e91efeb4433330ade590b98ff7f6884d5f9900d195bb386f52907e91b543ce416230 WHIRLPOOL c15643186c30258d1e590b5a233aea893f071750e4369d1d95b0ff818e077fe0f51415b2e15ff3524429882cd13880aa3a198b3c01ccc5450fe9e68feba39836
DIST winetricks-gentoo-2012.11.24.tar.bz2 6398 SHA256 dded8c294cc5c2e71e4a5d1531ab165178cf3d2d1d890d0656368c2e499bfeb9 SHA512 59c93b73f3a7b2d11aefcde2ff66659ff1de21ad4b5f232f4b60572f3a48b15a6c49f369b1696862bf1b33fde190bf5598945e9536fb41ddec42d8def4d2be2a WHIRLPOOL 268da9e06712a678fbbcfff8eac1fca364b5e46f0a9c48a591eb88f03260b1a55f203eb2908bfe1f0a534b77c866127ff6f7049b0e43fe8abeaaa26fe55de75b
diff --git a/app-emulation/winetricks/winetricks-20151116.ebuild b/app-emulation/winetricks/winetricks-20151116.ebuild
new file mode 100644
index 000000000000..dba352c251d9
--- /dev/null
+++ b/app-emulation/winetricks/winetricks-20151116.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit gnome2-utils eutils
+
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="git://github.com/Winetricks/${PN}.git"
+ inherit git-r3
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/Winetricks/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+wtg=winetricks-gentoo-2012.11.24
+SRC_URI="${SRC_URI}
+ gtk? ( https://dev.gentoo.org/~tetromino/distfiles/wine/${wtg}.tar.bz2 )
+ kde? ( https://dev.gentoo.org/~tetromino/distfiles/wine/${wtg}.tar.bz2 )"
+
+DESCRIPTION="Easy way to install DLLs needed to work around problems in Wine"
+HOMEPAGE="http://winetricks.org http://wiki.winehq.org/winetricks"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="gtk kde rar"
+
+DEPEND=""
+RDEPEND="app-arch/cabextract
+ app-arch/p7zip
+ app-arch/unzip
+ app-emulation/wine
+ net-misc/wget
+ x11-misc/xdg-utils
+ gtk? ( gnome-extra/zenity )
+ kde? ( kde-apps/kdialog )
+ rar? ( app-arch/unrar )"
+
+# Uses non-standard "Wine" category, which is provided by app-emulation/wine; #451552
+QA_DESKTOP_FILE="usr/share/applications/winetricks.desktop"
+
+# Tests require network access and run wine, which is unreliable from a portage environment
+RESTRICT="test"
+
+src_unpack() {
+ if [[ ${PV} == "99999999" ]] ; then
+ git-r3_src_unpack
+ if use gtk || use kde; then
+ unpack ${wtg}.tar.bz2
+ fi
+ else
+ default
+ fi
+}
+
+src_install() {
+ default
+ if use gtk || use kde; then
+ cd "${WORKDIR}/${wtg}" || die
+ domenu winetricks.desktop
+ insinto /usr/share/icons/hicolor/scalable/apps
+ doins wine-winetricks.svg
+ fi
+}
+
+pkg_preinst() {
+ if use gtk || use kde; then
+ gnome2_icon_savelist
+ fi
+}
+
+pkg_postinst() {
+ if use gtk || use kde; then
+ gnome2_icon_cache_update
+ fi
+}
+
+pkg_postrm() {
+ if use gtk || use kde; then
+ gnome2_icon_cache_update
+ fi
+}