summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-06-18 14:13:09 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-06-18 14:17:25 -0500
commit176ad6a7b289de6f34075f143baba099a7f0c23c (patch)
tree9d25f203d0207e6f64c38ceafcfb3c928e321795 /app-emulation
parentnet-misc/openssh: Allow root password logins for live-cd. (diff)
downloadgentoo-176ad6a7b289de6f34075f143baba099a7f0c23c.tar.gz
gentoo-176ad6a7b289de6f34075f143baba099a7f0c23c.tar.bz2
gentoo-176ad6a7b289de6f34075f143baba099a7f0c23c.zip
app-emulation/docker-compose: add version 1.7.1
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/docker-compose/Manifest1
-rw-r--r--app-emulation/docker-compose/docker-compose-1.7.1.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-emulation/docker-compose/Manifest b/app-emulation/docker-compose/Manifest
index 7d9e230593b4..1f289d12aa29 100644
--- a/app-emulation/docker-compose/Manifest
+++ b/app-emulation/docker-compose/Manifest
@@ -2,3 +2,4 @@ DIST docker-compose-1.5.2.tar.gz 106583 SHA256 79aa7e2e6ef9ab1936f8777476ffd4bb3
DIST docker-compose-1.6.2.tar.gz 128730 SHA256 264e2cbdd3fa314ba75f2681d10b0cff8d989a62979c1ba42d15a6d4c4002482 SHA512 7254a7e88b9030eeac87c1c6abfeea12e978519cc4e0236e37537c3143198d448e504107b1599b355a3c75e03e0acbd6fe552d0ff482cd3e91772d759a85544a WHIRLPOOL 3755ef9c189bd08f5bb810bf527041393ab788dcd302e6f1553989de73375ba34e062d2b21c10b144132ce9eb3997310b683b1b5b46aaf992fedfaa652deb6b2
DIST docker-compose-1.7.0.tar.gz 141480 SHA256 6fbf82d2df4bf1f9a614ea0100ac34e5b6e8cf95fab5a7e60a09d44a09da8576 SHA512 cd2f326b453c597e92a9869f014f7365adff4717163c30454c516ded84622d300e3a2ebabc5645ea3011e5aadc9fc34828db8da4bc122d07c9ccad5aae162c12 WHIRLPOOL 88e0fd717216a14ce7f85a6087e58659efe150851bcbdea26d0c9ca3073127dc32096228ef77451fc94c86254bb505fe1ef3e5baf0b266097a09f3496db87aa9
DIST docker-compose-1.7.0_rc1.tar.gz 140008 SHA256 ae4777e14fa64d2016f2dcbca34b39e2976150ca324241b68b5a82f753ee08ef SHA512 3405f59fae198633f7bb8ac8d9c94294d221751a551a91a96ac131f520cabec068a5aa4ba502c5e8eb9a3907e6f8527de2e39a12a66980ad978cb5b7d96cac06 WHIRLPOOL 82e2226a0fdf06b25da3da27ddf53739c0e583e290ce94747298c75aee5f8f37b353d1bcf1fe7e57e20daa53637ac36d9fb1787e8243176c7108f38e5a697b42
+DIST docker-compose-1.7.1.tar.gz 141471 SHA256 97460873bfa9228afee543881ff6f6f7e4c12ac81974a2fcfa40fce272b2934e SHA512 eca5bbcf3785131cb813ed58bd4b662a70d7516ce875ea18bbb17ebb74f5c4b8189081add8f5befa11a5583063209d1121978aaec8f69ef8dc7ae3a077e0965a WHIRLPOOL 3366c5a6fa9e1acf244ba128118cf65a1b8f2658c93ab5424d00ae9ab6b4ad2771ed34b50d5ff8ab200bb669a1ee2d91f636ee5750d65d311931b3df7baef1d1
diff --git a/app-emulation/docker-compose/docker-compose-1.7.1.ebuild b/app-emulation/docker-compose/docker-compose-1.7.1.ebuild
new file mode 100644
index 000000000000..04df9230ba7b
--- /dev/null
+++ b/app-emulation/docker-compose/docker-compose-1.7.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit bash-completion-r1 distutils-r1 vcs-snapshot
+
+MY_PV=${PV//_/}
+
+DESCRIPTION="Multi-container orchestration for Docker"
+HOMEPAGE="https://www.docker.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PN}-${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+CDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/cached-property-2[${PYTHON_USEDEP}]
+ >=dev-python/dockerpty-0.4.1[${PYTHON_USEDEP}]
+ <dev-python/dockerpty-0.5[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-1.8.1[${PYTHON_USEDEP}]
+ <dev-python/docker-py-2[${PYTHON_USEDEP}]
+ >=dev-python/docopt-0.6.1[${PYTHON_USEDEP}]
+ <dev-python/docopt-0.7[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.5.1[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ <dev-python/pyyaml-4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.6.1[${PYTHON_USEDEP}]
+ <dev-python/requests-2.8[${PYTHON_USEDEP}]
+ >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+ <dev-python/six-2[${PYTHON_USEDEP}]
+ >=dev-python/texttable-0.8.1[${PYTHON_USEDEP}]
+ <dev-python/texttable-0.9[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+ <dev-python/websocket-client-1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '<dev-python/enum34-2[${PYTHON_USEDEP}]' 'python2_7' )
+"
+DEPEND="
+ test? (
+ ${CDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' )
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_test() {
+ ${PYTHON} -m pytest tests/unit || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp contrib/completion/bash/docker-compose ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/completion/zsh/*
+
+ distutils-r1_python_install_all
+}