summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-04-12 18:49:59 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-04-12 18:55:23 +0200
commit2e22f341ef87b21d4e8f809ffed76a1850d56b2e (patch)
tree5efe3f53c5351d9961a58ee01000cf1f4e3313f4 /app-emulation
parentdev-python/aiohttp: Bump to 3.9.4 (diff)
downloadgentoo-2e22f341ef87b21d4e8f809ffed76a1850d56b2e.tar.gz
gentoo-2e22f341ef87b21d4e8f809ffed76a1850d56b2e.tar.bz2
gentoo-2e22f341ef87b21d4e8f809ffed76a1850d56b2e.zip
app-emulation/virt-firmware: add 24.4
Closes: https://bugs.gentoo.org/929222 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/virt-firmware/Manifest1
-rw-r--r--app-emulation/virt-firmware/virt-firmware-24.4.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-emulation/virt-firmware/Manifest b/app-emulation/virt-firmware/Manifest
index f68b8b01eb48..3d4823583d8f 100644
--- a/app-emulation/virt-firmware/Manifest
+++ b/app-emulation/virt-firmware/Manifest
@@ -1,3 +1,4 @@
DIST virt-firmware-24.2.tar.gz 110844 BLAKE2B db7ad7663678a313bdd0e23de7e374547e5dbc1a04b37a65e366ae042410a3a6c21ccfef3747a2534cb76906868caaf1364ac1ecd1443c1c1053a5b7687da50b SHA512 8583420acb31fb32e4c195c0c1816b36248ec2e486ded0795e51180e2690b2bcdc10eb8707f4fc9fa36da5b24082737c5c3b2e3988f6c5455e08a5d2a0ff92e7
DIST virt-firmware-24.2_p20240402.tar.gz 106875 BLAKE2B cdc6bde95a7db347e896c3d33e7ad0715c5a6cbb9a80dbcfb87379bb0f7693c0b96544cb3a1394ce115cfe98321d79339b682f02250930b85ff4bef35d038251 SHA512 50899655fe76e7ed71d3a607030a2067ae97f15f0d3698a54ec388ac6e27e2c2f39b2b4cb5552dad17e184124d62f70d045bc8b5b1f6c5931d477a911be11637
DIST virt-firmware-24.2_p20240412.tar.gz 107558 BLAKE2B 7412ba0d822dbaee57dc7486805f244ffa43abb2452daa984ca2e878a9fe02d429f525af915e935ee1fc2f1ee2a547858dea48be3cae1ed7fbc37bb142171587 SHA512 0a36f473c9b8f6a26c1e80758bd89a279456a4d76af6ee68200ca80c7da316a3cc4646e76dba248f6f90ace7365bbf9cfb682bab9923b88ae35283631dd7ffb0
+DIST virt-firmware-24.4.tar.gz 111964 BLAKE2B 16005a6f911abf227988abaedd45237d44d403f367abd3c2d413f899a6c3e7db2a62edcd36b7408263f101a0f0a20bbea83bf51f7f798077311b478dfc6c9fc1 SHA512 3b13df25177fe5c20e460e2d82453e23ae96cb657f1228ff1c061db4c4197eba719a4d7f51a90fec60a4de2da9a0e9d3f056d53011bd4f61df7f40b706911a1d
diff --git a/app-emulation/virt-firmware/virt-firmware-24.4.ebuild b/app-emulation/virt-firmware/virt-firmware-24.4.ebuild
new file mode 100644
index 000000000000..36b536044e18
--- /dev/null
+++ b/app-emulation/virt-firmware/virt-firmware-24.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1 optfeature pypi systemd
+
+DESCRIPTION="Tools for ovmf/armvirt firmware volumes"
+HOMEPAGE="
+ https://gitlab.com/kraxel/virt-firmware
+ https://pypi.org/project/virt-firmware/
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+# Currently requires files in /boot and read/write to efivars
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pefile[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest tests
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ doman man/*.1
+
+ doinitd "${FILESDIR}/kernel-bootcfg-boot-successful"
+ systemd_dounit systemd/kernel-bootcfg-boot-successful.service
+
+ # Use our own provided by sys-kernel/installkernel[efistub,systemd]
+ #exeinto /usr/lib/kernel/install.d
+ #doexe systemd/99-uki-uefi-setup.install
+}
+
+pkg_postinst() {
+ optfeature "automatically updating UEFI configuration on each kernel installation or removal" \
+ "sys-kernel/installkernel[systemd,efistub]"
+}