summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-14 22:36:18 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-15 00:06:32 +0100
commit351d831a47debd4443badf35c3a8859e0fb23d68 (patch)
tree3d5b85e44d071685367085ae8541be2de7f32000 /app-emulation
parentapp-editors/focuswriter: 1.7.1 version bump, EAPI-7 bump (diff)
downloadgentoo-351d831a47debd4443badf35c3a8859e0fb23d68.tar.gz
gentoo-351d831a47debd4443badf35c3a8859e0fb23d68.tar.bz2
gentoo-351d831a47debd4443badf35c3a8859e0fb23d68.zip
app-emulation/q4wine: 1.3.11 version bump
Switch from gnome2-utils to xdg, EAPI-7 bump Thanks-to: John Brezerk <brezerk@gmail.com> Closes: https://bugs.gentoo.org/665708 Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/q4wine/Manifest1
-rw-r--r--app-emulation/q4wine/q4wine-1.3.11.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-emulation/q4wine/Manifest b/app-emulation/q4wine/Manifest
index 79a90fcb6851..1fab7409ce92 100644
--- a/app-emulation/q4wine/Manifest
+++ b/app-emulation/q4wine/Manifest
@@ -1 +1,2 @@
+DIST q4wine-1.3.11.tar.bz2 2868845 BLAKE2B 98893b1f65bcb8b8f301d7046a650658a9537849818fddf4803471a626f24d8c812867daec1f167b1fa5cdce9f9c0c50323d715ea06c51f3d52f85904257d2b0 SHA512 95ac66632bc46b10659e1d0e5f3c68b73934a85ddcc6582abd367d28f9949ad0ca732a5596db800bbc76b40ae7cf05fd95febf6d8b44db20cf710c2c1e23288f
DIST q4wine-1.3.6.tar.bz2 2867547 BLAKE2B b35a638e514108e4ee4be34b446a7d2d5ba00415d8f54cfee293988707b637d41945d3197a2132147e09d5a05153fd47a55701dcba358f3a2b3a2e6037f78aaa SHA512 1ff0ea2a4523fc5582ec67f5e305622653c4e387ac5f2cecde52289117ef879a60261fdbf9ddf421812765539124d4c5b6b37ff401530d3e061723a3c35d57f8
diff --git a/app-emulation/q4wine/q4wine-1.3.11.ebuild b/app-emulation/q4wine/q4wine-1.3.11.ebuild
new file mode 100644
index 000000000000..3466e650c02d
--- /dev/null
+++ b/app-emulation/q4wine/q4wine-1.3.11.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg cmake-utils
+
+# Upstream names the package PV-rX. We change that to
+# PV_pX so we can use portage revisions.
+MY_P=${PN}-${PV/_p/-r}
+
+DESCRIPTION="Qt GUI configuration tool for Wine"
+HOMEPAGE="https://q4wine.brezblock.org.ua/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+dbus debug +ico +iso +wineappdb"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsingleapplication[qt5(+),X]
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ dbus? ( dev-qt/qtdbus:5 )
+ ico? ( >=media-gfx/icoutils-0.26.0 )
+"
+RDEPEND="${DEPEND}
+ app-admin/sudo
+ >=sys-apps/which-2.19
+ iso? ( sys-fs/fuseiso )
+"
+
+S="${WORKDIR}"/${MY_P}
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_configure() {
+ local mycmakeargs=(
+ -DDEBUG=$(usex debug ON OFF)
+ -DWITH_ICOUTILS=$(usex ico ON OFF)
+ -DWITH_SYSTEM_SINGLEAPP=ON
+ -DWITH_WINEAPPDB=$(usex wineappdb ON OFF)
+ -DUSE_BZIP2=OFF
+ -DUSE_GZIP=OFF
+ -DWITH_DBUS=$(usex dbus ON OFF)
+ )
+ cmake-utils_src_configure
+}