summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-04-22 15:43:39 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-04-22 16:31:12 -0400
commit420196d3ea6c3610a6858ade463fd79a838941e6 (patch)
treed9aae5d764b4095dc8b8f2760e3d2c6d84097cfc /app-emulation
parentapp-emulation/wine-vanilla: drop 9.3, 9.4 (diff)
downloadgentoo-420196d3ea6c3610a6858ade463fd79a838941e6.tar.gz
gentoo-420196d3ea6c3610a6858ade463fd79a838941e6.tar.bz2
gentoo-420196d3ea6c3610a6858ade463fd79a838941e6.zip
app-emulation/wine-vanilla: "fix" build with gcc-14 for old branches
Unsure how much is broken, but for wine-7+8 it doesn't seem worth the effort to backport. No issues I can see with wine-9. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild4
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-8.0.2.ebuild4
2 files changed, 8 insertions, 0 deletions
diff --git a/app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild b/app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild
index ed678fefaa02..88eaa6f3c226 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild
@@ -265,6 +265,10 @@ src_configure() {
[[ $($(tc-getCC) ${LDFLAGS} -Wl,--version 2>/dev/null) == mold* ]] &&
append-ldflags -fuse-ld=bfd
+ # >=wine-vanilla-9 has proper fixes and builds with gcc-14, but
+ # would rather not have to worry about fixing old branches
+ append-cflags $(test-flags-CC -Wno-error=incompatible-pointer-types)
+
# build using upstream's way (--with-wine64)
# order matters: configure+compile 64->32, install 32->64
local -i bits
diff --git a/app-emulation/wine-vanilla/wine-vanilla-8.0.2.ebuild b/app-emulation/wine-vanilla/wine-vanilla-8.0.2.ebuild
index 972a6b64c743..f0641aa921fe 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-8.0.2.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-8.0.2.ebuild
@@ -259,6 +259,10 @@ src_configure() {
[[ $($(tc-getCC) ${LDFLAGS} -Wl,--version 2>/dev/null) == mold* ]] &&
append-ldflags -fuse-ld=bfd
+ # >=wine-vanilla-9 has proper fixes and builds with gcc-14, but
+ # would rather not have to worry about fixing old branches
+ append-cflags $(test-flags-CC -Wno-error=incompatible-pointer-types)
+
# build using upstream's way (--with-wine64)
# order matters: configure+compile 64->32, install 32->64
local -i bits