summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2021-02-18 03:09:32 +0100
committerSebastian Pipping <sping@gentoo.org>2021-02-18 03:09:32 +0100
commit486f257b1b2623b61419be7845927ee455262a18 (patch)
tree09d9b28c3cfc0264e20f74beed27299fa7d4eba5 /app-emulation
parentdev-python/docker-py: 4.4.2 (diff)
downloadgentoo-486f257b1b2623b61419be7845927ee455262a18.tar.gz
gentoo-486f257b1b2623b61419be7845927ee455262a18.tar.bz2
gentoo-486f257b1b2623b61419be7845927ee455262a18.zip
app-emulation/docker-compose: 1.28.3
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.14, Repoman-3.0.2
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/docker-compose/Manifest1
-rw-r--r--app-emulation/docker-compose/docker-compose-1.28.3.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/app-emulation/docker-compose/Manifest b/app-emulation/docker-compose/Manifest
index cdd2d5e78c7e..e398a4d17dfa 100644
--- a/app-emulation/docker-compose/Manifest
+++ b/app-emulation/docker-compose/Manifest
@@ -1,3 +1,4 @@
DIST docker-compose-1.27.4.tar.gz 309308 BLAKE2B 098af5e0308de4fe72f8f7d5c9cbdb285ec1cb6fbd492baef8a4223f93591321c585ebabd4c7e4a40d7a1bce3ab2d7ccf4cee1d0a15e7f59bb80eb4df5b6c8d6 SHA512 b41b7cf88b1380021a30f9becb7567d1e154ef875c42b37483673b5107f1a26dae6868b92c6a61f695001eb63759b25f3729e6783272eb784047717cafea3b80
DIST docker-compose-1.28.0.tar.gz 318112 BLAKE2B 2e721f2aed08f8c63c7c75aa91e6ee28d997763a7d93921e9a62c41b7d48943221aa2135e6ba3925db67b2376f662f81ef71df15180895ea4d5ced1edd0cc493 SHA512 c673f25ff993e7dcaf75512c378339bb7435d96310bf9a47ee3fd3a515967b323ed911b77c030a8e9c1d04b8aca235565a0ca0eaeab401c4ac48110712da405e
DIST docker-compose-1.28.2.tar.gz 318196 BLAKE2B 60827043135b1b1455ce0fe8cd3b6bdfad025af80d32b805e7a7a9df7949808b6575555e860a2d0f57bf07af44cb7847b38146accbb2c4eec9a8919bc4ec4141 SHA512 ababba47717e31187243478ba4a9d4082e2f64a05a0bf48cbafb2a44b62138d7dfb1cbb88da4c388b559cb35d53bcf4c42617f6ae02412b7a65f02cb09255e45
+DIST docker-compose-1.28.3.tar.gz 318055 BLAKE2B 06295dd77bafe191afc8f83f90c5763d8c8804caaf1c7a7f0866760297b212bf8fc4b6735ebf2bdda44f373d91ae1bd1398e7477b1e9e10bddf3db22885ae667 SHA512 d1bd5d2e82dcd44f37d5ff23d1f781e72bffe298245c1d54f0b4b00f0ed950f8896154ce35d265f010dd1422c7ad00c0785489383c123579786e30c82eb7f637
diff --git a/app-emulation/docker-compose/docker-compose-1.28.3.ebuild b/app-emulation/docker-compose/docker-compose-1.28.3.ebuild
new file mode 100644
index 000000000000..1a14270fa5a4
--- /dev/null
+++ b/app-emulation/docker-compose/docker-compose-1.28.3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 2018-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit bash-completion-r1 distutils-r1
+
+MY_PV=${PV/_/-}
+DESCRIPTION="Multi-container orchestration for Docker"
+HOMEPAGE="https://github.com/docker/compose"
+SRC_URI="https://github.com/docker/compose/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/distro-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-4.4.2[${PYTHON_USEDEP}]
+ >=dev-python/dockerpty-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/docopt-0.6.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dotenv-0.13.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.5.1[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ >=dev-python/PySocks-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/texttable-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/pytest-5[${PYTHON_USEDEP}]
+ >=dev-python/ddt-1.2.2[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/compose-${MY_PV}"
+
+PATCHES=(
+ # Bug #679968 -- https://bugs.gentoo.org/679968
+ # Bug #681002 -- https://bugs.gentoo.org/681002
+ "${FILESDIR}"/${PN}-1.28.0_rc2-setup-py.patch
+)
+
+DOCS=( CHANGELOG.md README.md )
+
+src_prepare() {
+ # Address QA issue "docker-compose.exe: missing alias (symlink) for completed command."
+ sed 's,^\(complete.*\) docker-compose\.exe\(.*\),\1\2,' -i contrib/completion/bash/docker-compose || die
+
+ default
+}
+
+python_test() {
+ distutils_install_for_testing
+ ${PYTHON} -m pytest tests/unit/ || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp contrib/completion/bash/docker-compose ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/completion/zsh/*
+
+ distutils-r1_python_install_all
+}