summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-03-12 00:42:34 +0000
committerMarek Szuba <marecki@gentoo.org>2022-03-12 00:42:34 +0000
commit6c41cbb468530c0a2ea8b50ddb48368bc97e4746 (patch)
tree9821d7a4b2bd66dc8ec4046dcea1b0093f7690eb /app-emulation
parentsys-apps/flashrom: remove another 9999-only local use flag (diff)
downloadgentoo-6c41cbb468530c0a2ea8b50ddb48368bc97e4746.tar.gz
gentoo-6c41cbb468530c0a2ea8b50ddb48368bc97e4746.tar.bz2
gentoo-6c41cbb468530c0a2ea8b50ddb48368bc97e4746.zip
app-emulation/protontricks: add 1.8.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/protontricks/Manifest1
-rw-r--r--app-emulation/protontricks/protontricks-1.8.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/app-emulation/protontricks/Manifest b/app-emulation/protontricks/Manifest
index 45a071f9157a..8dacce3460df 100644
--- a/app-emulation/protontricks/Manifest
+++ b/app-emulation/protontricks/Manifest
@@ -1 +1,2 @@
DIST protontricks-1.7.0.tar.gz 139203 BLAKE2B d93bbb672286d32743da1473e132508084bae527159911367c51e88686c38d3bad0a2f72a2c0f0feb09412e31e6d5bb20dfe113b9e71e4e655693bfbe663a968 SHA512 c12f211051bc23c8eb03c5385e8245361d72dcce1e641a7da1f87f344db5fdc7d698bd7691e0855ae025c1d94944db89b380805664d87123b6252d06259480ff
+DIST protontricks-1.8.0.tar.gz 145619 BLAKE2B 5a7e5040c646838574abd06ac628d6c004f26ad8406bfefd8f24dc5a8438c4ba19bd5b848911141b58faf7431e3ee88e3f5f82735154eeaf7179f7ec4643634e SHA512 db688663b0e82089ea218c256c7fae6b9222572e7213cecb26bfa68de59eb0c6c95bb0b39b138e180f7bcda27d8d0c33bcd8a3ff3c4009815dcfe1c73be702c6
diff --git a/app-emulation/protontricks/protontricks-1.8.0.ebuild b/app-emulation/protontricks/protontricks-1.8.0.ebuild
new file mode 100644
index 000000000000..cfb253df8379
--- /dev/null
+++ b/app-emulation/protontricks/protontricks-1.8.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="app-emulation/winetricks wrapper for Proton (Steam Play) games"
+HOMEPAGE="https://github.com/Matoking/protontricks"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+gui"
+
+RDEPEND="app-emulation/winetricks
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/vdf[${PYTHON_USEDEP}]
+ ')
+ gui? ( gnome-extra/zenity
+ || (
+ app-emulation/winetricks[gtk]
+ app-emulation/winetricks[kde]
+ )
+ )"
+BDEPEND="$(python_gen_cond_dep '
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+')"
+
+DOCS=( CHANGELOG.md README.md )
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ echo "version = '${PV}'" > "${S}"/src/${PN}/_version.py || die "Failed to generate the version file"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ elog
+
+ if ! use gui; then
+ ewarn "Please note that disabling USE=gui does *not* presently remove the --gui command-line option,"
+ ewarn "it just means using this option will fail unless gnome-extra/zenity happens to be installed."
+ ewarn
+ fi
+
+ elog "Protontricks can only find games for which a Proton prefix already exists."
+ elog "Make sure to run a Proton game at least once before trying to use protontricks on it."
+ elog
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}