summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2023-01-10 15:27:42 +0300
committerJoonas Niilola <juippis@gentoo.org>2023-01-24 12:01:30 +0200
commit851464a2377bd537ba380deca5529aebf0a806d4 (patch)
treeb60279b63b51baac352013946af5cd9c2f94eb0b /app-emulation
parentwww-client/firefox: update patchset for 109.0 (diff)
downloadgentoo-851464a2377bd537ba380deca5529aebf0a806d4.tar.gz
gentoo-851464a2377bd537ba380deca5529aebf0a806d4.tar.bz2
gentoo-851464a2377bd537ba380deca5529aebf0a806d4.zip
app-emulation/punes: add 0.110
Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/punes/Manifest1
-rw-r--r--app-emulation/punes/punes-0.110.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-emulation/punes/Manifest b/app-emulation/punes/Manifest
index a66b48126126..2efb7fac9f3e 100644
--- a/app-emulation/punes/Manifest
+++ b/app-emulation/punes/Manifest
@@ -1,3 +1,4 @@
DIST punes-0.107.tar.gz 44024138 BLAKE2B 048df5bc9b019bafcd4eec75dc027de7cde9f8aa0d484ef96e5c41b091ba55c13b84ef7c7c36987b53206b1b7027758534479d0cc9fde63d89a48092c3f9d26d SHA512 eb3b7aa1c18765402e1e57e23dd4b019255320b795c0f578a4d5ae9f4e0c163613da07280e2a5abed80b9ba90e74c80b53b5fdd80e405103f0063ca55d0ee7bd
DIST punes-0.109.tar.gz 48695769 BLAKE2B cc5a86b2f99dc3c97bc04386568fcb926d2a9c83f8c6dcaf28c022a136791ff481610ad578c996c643e0c0b107acb2be9a0fbfda0950435aad984f3506ec1983 SHA512 13cf3587c9936ff9f933d3394516d25fbd664fc2fd510af724c3bbbc6fefb12a019e8fe27cd52cd326ef8fba3721f4e1816ce5d3f3935f701081a142f04a3bc2
DIST punes-0.109_musl.patch.xz 5520 BLAKE2B ea1c36d510303dd67b7e2005a3f099e328583c9762f74ccf9457a5f04268c44243b4fe18fc6498c176a999318f40c9a34ca2a3ed7de2d4dea953ab055901ad42 SHA512 507163d40849bbf782725f71409432a0cb4a79f5c3fccfaf78786322539a1bce0608b731a75c817b72f8a4e814d0cb21019cb23f621176042fb946754a4a9292
+DIST punes-0.110.tar.gz 49500935 BLAKE2B c4704ad6edc828f6332798e44939dc82e86fb0fed1d7a71e3377c7bb384a7fc40d2b9303dff13b1e92cf4bb189a5c4816c5c6ec2f2db1ab1c5d58d459b6c1ed9 SHA512 e0f503ac8c0cd0257eebb1401a6cf5045d03e348a5f915574b47c15930c029c93e36f5776c1364b7c7b6a27faa48a36173c4fd0342f24e9a3241ebd5e0a9d137
diff --git a/app-emulation/punes/punes-0.110.ebuild b/app-emulation/punes/punes-0.110.ebuild
new file mode 100644
index 000000000000..9a5f143123d4
--- /dev/null
+++ b/app-emulation/punes/punes-0.110.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="Nintendo Entertainment System (NES) emulator"
+HOMEPAGE="https://github.com/punesemu/puNES"
+SRC_URI="https://github.com/punesemu/puNES/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/puNES-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X cg ffmpeg"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ media-libs/alsa-lib
+ media-libs/libglvnd[X?]
+ virtual/glu
+ virtual/udev
+ X? (
+ x11-libs/libX11
+ x11-libs/libXrandr
+ )
+ cg? ( media-gfx/nvidia-cg-toolkit )
+ ffmpeg? ( media-video/ffmpeg:= )"
+DEPEND="
+ ${RDEPEND}
+ X? ( x11-base/xorg-proto )"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_GIT_INFO=OFF
+ -DENABLE_QT6_LIBS=OFF
+ -DDISABLE_PORTABLE_MODE=OFF
+ -DENABLE_FFMPEG=$(usex ffmpeg)
+ -DENABLE_FULLSCREEN_RESFREQ=$(usex X)
+ -DENABLE_OPENGL_CG=$(usex cg)
+ )
+ cmake_src_configure
+}