summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Gaydarov <git@gg7.io>2017-11-24 21:23:20 +0000
committerMatthias Maier <tamiko@gentoo.org>2017-12-20 21:00:24 -0600
commit98bce0c3bdf492bc9fcb83cdee7e627f81bea663 (patch)
treeb06a92e251cd86d5790dba4cd3c48303d7d01e6e /app-emulation
parentprofiles: Drop obsolete sci-geosciences/qgis package.mask (diff)
downloadgentoo-98bce0c3bdf492bc9fcb83cdee7e627f81bea663.tar.gz
gentoo-98bce0c3bdf492bc9fcb83cdee7e627f81bea663.tar.bz2
gentoo-98bce0c3bdf492bc9fcb83cdee7e627f81bea663.zip
app-emulation/qemu: Make CONFIG_CHECK CPU-model dependent
Closes: https://github.com/gentoo/gentoo/pull/6285 Signed-off-by: George Gaydarov <git@gg7.io> Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu/qemu-2.10.1-r1.ebuild (renamed from app-emulation/qemu/qemu-2.10.1.ebuild)6
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild6
2 files changed, 10 insertions, 2 deletions
diff --git a/app-emulation/qemu/qemu-2.10.1.ebuild b/app-emulation/qemu/qemu-2.10.1-r1.ebuild
index 944fecea9676..dcf84b71ab60 100644
--- a/app-emulation/qemu/qemu-2.10.1.ebuild
+++ b/app-emulation/qemu/qemu-2.10.1-r1.ebuild
@@ -286,7 +286,11 @@ pkg_pretend() {
ERROR_VHOST_NET+=" support"
if use amd64 || use x86 || use amd64-linux || use x86-linux; then
- CONFIG_CHECK+=" ~KVM_AMD ~KVM_INTEL"
+ if grep -q AuthenticAMD /proc/cpuinfo; then
+ CONFIG_CHECK+=" ~KVM_AMD"
+ elif grep -q GenuineIntel /proc/cpuinfo; then
+ CONFIG_CHECK+=" ~KVM_INTEL"
+ fi
fi
use python && CONFIG_CHECK+=" ~DEBUG_FS"
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index 1f09b78248a4..97e3556cc400 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -283,7 +283,11 @@ pkg_pretend() {
ERROR_VHOST_NET+=" support"
if use amd64 || use x86 || use amd64-linux || use x86-linux; then
- CONFIG_CHECK+=" ~KVM_AMD ~KVM_INTEL"
+ if grep -q AuthenticAMD /proc/cpuinfo; then
+ CONFIG_CHECK+=" ~KVM_AMD"
+ elif grep -q GenuineIntel /proc/cpuinfo; then
+ CONFIG_CHECK+=" ~KVM_INTEL"
+ fi
fi
use python && CONFIG_CHECK+=" ~DEBUG_FS"