summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Ziak <0xe2.0x9a.0x9b@gmail.com>2018-12-12 12:05:12 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-16 20:29:10 +0100
commit9cc0df82cb3f6f8412884e4be4575912c758cc07 (patch)
treec6e519b39ad4a3fdf0733630d8f95ca74488aecd /app-emulation
parentsys-auth/sssd: Drop old (diff)
downloadgentoo-9cc0df82cb3f6f8412884e4be4575912c758cc07.tar.gz
gentoo-9cc0df82cb3f6f8412884e4be4575912c758cc07.tar.bz2
gentoo-9cc0df82cb3f6f8412884e4be4575912c758cc07.zip
app-emulation/fuse: bump to version 1.5.7
Signed-off-by: Jan Ziak <0xe2.0x9a.0x9b@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/10620 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/fuse/Manifest1
-rw-r--r--app-emulation/fuse/fuse-1.5.7.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/app-emulation/fuse/Manifest b/app-emulation/fuse/Manifest
index f235497c34d2..73ba09ac7b9f 100644
--- a/app-emulation/fuse/Manifest
+++ b/app-emulation/fuse/Manifest
@@ -1,2 +1,3 @@
DIST fuse-1.5.5.tar.gz 1629577 BLAKE2B b4765047507049b2fa3547d47384df2c5e6de75b74b7aa8d3549ca47ae6f3dad53a37fc48112db86426ce3d2d84711aa029d158c75eba89214761ed82d7ab57a SHA512 186635b632df9767b9ffcbba484370adc47833bd06240474db9c4dfe88b03209e15fc0c86a2f200b2cc7bd95ad93bf1f93f38d7f669b5c163f68e80802fb1041
DIST fuse-1.5.6.tar.gz 1634711 BLAKE2B a581c106c668f0342b4a3b4ebbc0e92e750806e59d067798e23da02284cbb9a17cf580c5b6369144863fbf64b12326ea2982e4d83e87354d62ff51926e3293de SHA512 84312e4f83883b36d06f2b96ded1bfc71675cba71a0848f4cbb5a233a1d1c06466013d2655d759397f32d6d67d6ba26b2b6a5041796cb9143cd0b354a88fd589
+DIST fuse-1.5.7.tar.gz 1634568 BLAKE2B 9d2f3c310132dc57336995c31adeb37d727506719d1089b2009a2f44cbfa59fc9c4e9252aeff64cdd22b7326328518b5da33af51be687f321b891b9d1dd2b646 SHA512 ac11e03fc203f98433253fb72d7700cf6285ad8662147f318bb4ceda3888bc865b80d85473a3b2bda9e0971989b1579fc928f41ddabbf01d58358362066be13d
diff --git a/app-emulation/fuse/fuse-1.5.7.ebuild b/app-emulation/fuse/fuse-1.5.7.ebuild
new file mode 100644
index 000000000000..0e1754ea0792
--- /dev/null
+++ b/app-emulation/fuse/fuse-1.5.7.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Free Unix Spectrum Emulator by Philip Kendall"
+HOMEPAGE="http://fuse-emulator.sourceforge.net"
+SRC_URI="mirror://sourceforge/fuse-emulator/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa ao backend-fbcon backend-sdl backend-svga backend-X gpm joystick memlimit png xml"
+
+# Only one UI back-end can be enabled at a time
+REQUIRED_USE="?? ( backend-fbcon backend-sdl backend-svga backend-X )"
+
+RDEPEND="
+ >=app-emulation/libspectrum-1.4.4
+ dev-libs/glib:2
+ alsa? ( media-libs/alsa-lib )
+ ao? ( media-libs/libao )
+ backend-sdl? ( media-libs/libsdl )
+ backend-svga? ( media-libs/svgalib )
+ backend-X? ( x11-libs/libX11 x11-libs/libXext )
+ !backend-fbcon? ( !backend-sdl? ( !backend-svga? ( !backend-X? ( x11-libs/gtk+:3 ) ) ) )
+ gpm? ( sys-libs/gpm )
+ joystick? ( media-libs/libjsw )
+ png? ( media-libs/libpng:0= sys-libs/zlib )
+ xml? ( dev-libs/libxml2:2 )"
+DEPEND="${RDEPEND}
+ backend-fbcon? ( virtual/linux-sources )
+ dev-lang/perl
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog README THANKS )
+
+src_configure() {
+ local myconf=(
+ --without-win32
+ $(use_with alsa)
+ $(use_with ao libao)
+ $(use_with gpm)
+ $(use_with joystick)
+ $(use_enable joystick ui-joystick)
+ $(use_enable memlimit smallmem)
+ $(use_with png)
+ $(use_with xml libxml2)
+ )
+
+ if use backend-sdl; then
+ myconf+=("--with-sdl")
+ elif use backend-X; then
+ myconf+=("--without-gtk")
+ elif use backend-svga; then
+ myconf+=("--with-svgalib")
+ elif use backend-fbcon; then
+ myconf+=("--with-fb")
+ else
+ myconf+=("--with-gtk")
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ emake test
+}