summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Privoznik <mprivozn@redhat.com>2019-01-11 10:52:13 +0100
committerMatthias Maier <tamiko@gentoo.org>2019-01-12 20:18:38 -0600
commitac46cbdeaad72eefe4f8f2d35bc2e3b41c4d11f4 (patch)
tree64105477a63af10b1a5f8a71c3cab51bfe87c744 /app-emulation
parentmail-mta/msmtp: Bump to version 1.8.2 (diff)
downloadgentoo-ac46cbdeaad72eefe4f8f2d35bc2e3b41c4d11f4.tar.gz
gentoo-ac46cbdeaad72eefe4f8f2d35bc2e3b41c4d11f4.tar.bz2
gentoo-ac46cbdeaad72eefe4f8f2d35bc2e3b41c4d11f4.zip
app-emulation/libvirt: Rebase patches for 5.0.0 release
In the upstream repo a few changes were made that rendered our patches inapplicable (mostly a520981740015 and 6ee53e54dcfa3285ed7). Signed-off-by: Michal Privoznik <mprivozn@redhat.com> Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/libvirt/files/libvirt-5.0.0-do-not-use-sysconf.patch216
-rw-r--r--app-emulation/libvirt/files/libvirt-5.0.0-fix-paths-for-apparmor.patch110
-rw-r--r--app-emulation/libvirt/libvirt-9999.ebuild4
3 files changed, 328 insertions, 2 deletions
diff --git a/app-emulation/libvirt/files/libvirt-5.0.0-do-not-use-sysconf.patch b/app-emulation/libvirt/files/libvirt-5.0.0-do-not-use-sysconf.patch
new file mode 100644
index 000000000000..d4e37e4164a1
--- /dev/null
+++ b/app-emulation/libvirt/files/libvirt-5.0.0-do-not-use-sysconf.patch
@@ -0,0 +1,216 @@
+From 947ef7a44e94989f324e0d533499454d540fdef9 Mon Sep 17 00:00:00 2001
+Message-Id: <947ef7a44e94989f324e0d533499454d540fdef9.1547196492.git.mprivozn@redhat.com>
+From: Michal Privoznik <mprivozn@redhat.com>
+Date: Tue, 26 Jun 2018 06:51:06 +0200
+Subject: [PATCH] gentoo: do not use sysconf
+
+Signed-off-by: Michal Privoznik <mprivozn@redhat.com>
+---
+ src/Makefile.am | 29 ++++++-----------------------
+ src/locking/virtlockd.service.in | 3 +--
+ src/logging/virtlogd.service.in | 3 +--
+ src/remote/libvirtd.service.in | 3 +--
+ tools/Makefile.am | 17 ++++-------------
+ tools/libvirt-guests.service.in | 2 +-
+ tools/libvirt-guests.sysconf | 7 +++++++
+ 7 files changed, 21 insertions(+), 43 deletions(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index cd386297ed..52a63885d6 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -756,23 +756,6 @@ endif WITH_SETUID_RPC_CLIENT
+
+ EXTRA_DIST += $(SYSCONF_FILES)
+
+-install-sysconfig:
+- $(MKDIR_P) $(DESTDIR)$(sysconfdir)/sysconfig
+- for f in $(SYSCONF_FILES:%.sysconf=%) ; \
+- do \
+- tgt=`basename $$f`; \
+- $(INSTALL_DATA) $(srcdir)/$$f.sysconf \
+- $(DESTDIR)$(sysconfdir)/sysconfig/$$tgt; \
+- done
+-
+-uninstall-sysconfig:
+- for f in $(SYSCONF_FILES:%.sysconf=%) ; \
+- do \
+- tgt=`basename $$f`; \
+- rm -f $(DESTDIR)$(sysconfdir)/sysconfig/$$tgt; \
+- done
+- rmdir $(DESTDIR)$(sysconfdir)/sysconfig || :
+-
+ SYSVINIT_FILES_IN += \
+ locking/virtlockd.init.in \
+ $(NULL)
+@@ -816,14 +799,14 @@ if WITH_LIBVIRTD
+ if LIBVIRT_INIT_SCRIPT_RED_HAT
+ initdir = $(sysconfdir)/rc.d/init.d
+
+-install-init:: $(SYSVINIT_FILES) install-sysconfig
++install-init:: $(SYSVINIT_FILES)
+ $(MKDIR_P) $(DESTDIR)$(initdir)
+ for f in $(SYSVINIT_FILES:%.init=%) ; \
+ do \
+ $(INSTALL_SCRIPT) $$f.init $(DESTDIR)$(initdir)/$$f; \
+ done
+
+-uninstall-init:: uninstall-sysconfig
++uninstall-init::
+ rm -f $(SYSVINIT_FILES:%.init=$(DESTDIR)$(initdir)/%)
+ rmdir $(DESTDIR)$(initdir) || :
+
+@@ -862,14 +845,14 @@ SYSTEMD_UNIT_FILES = $(notdir $(SYSTEMD_UNIT_FILES_IN:%.in=%))
+ BUILT_SOURCES += $(SYSTEMD_UNIT_FILES)
+ DISTCLEANFILES += $(SYSTEMD_UNIT_FILES)
+
+-install-systemd: $(SYSTEMD_UNIT_FILES) install-sysconfig
++install-systemd: $(SYSTEMD_UNIT_FILES)
+ $(MKDIR_P) $(DESTDIR)$(SYSTEMD_UNIT_DIR)
+ for f in $(SYSTEMD_UNIT_FILES); \
+ do \
+ $(INSTALL_DATA) $$f $(DESTDIR)$(SYSTEMD_UNIT_DIR)/ ; \
+ done
+
+-uninstall-systemd: uninstall-sysconfig
++uninstall-systemd:
+ rm -f $(SYSTEMD_UNIT_FILES:%=$(DESTDIR)$(SYSTEMD_UNIT_DIR)/%)
+ rmdir $(DESTDIR)$(SYSTEMD_UNIT_DIR) || :
+
+@@ -884,7 +867,7 @@ EXTRA_DIST += $(UPSTART_FILES)
+ if WITH_LIBVIRTD
+ if LIBVIRT_INIT_SCRIPT_UPSTART
+
+-install-upstart: install-sysconfig
++install-upstart:
+ $(MKDIR_P) $(DESTDIR)$(sysconfdir)/event.d
+ for f in $(UPSTART_FILES:%.upstart=%); \
+ do \
+@@ -893,7 +876,7 @@ install-upstart: install-sysconfig
+ $(DESTDIR)$(sysconfdir)/event.d/$$tgt ; \
+ done
+
+-uninstall-upstart: uninstall-sysconfig
++uninstall-upstart:
+ for f in $(UPSTART_FILES:%.upstart=%); \
+ do \
+ tgt=`basename $$f` ; \
+diff --git a/src/locking/virtlockd.service.in b/src/locking/virtlockd.service.in
+index 3c9d587032..2449b201d9 100644
+--- a/src/locking/virtlockd.service.in
++++ b/src/locking/virtlockd.service.in
+@@ -7,8 +7,7 @@ Documentation=man:virtlockd(8)
+ Documentation=https://libvirt.org
+
+ [Service]
+-EnvironmentFile=-/etc/sysconfig/virtlockd
+-ExecStart=@sbindir@/virtlockd $VIRTLOCKD_ARGS
++ExecStart=@sbindir@/virtlockd
+ ExecReload=/bin/kill -USR1 $MAINPID
+ # Loosing the locks is a really bad thing that will
+ # cause the machine to be fenced (rebooted), so make
+diff --git a/src/logging/virtlogd.service.in b/src/logging/virtlogd.service.in
+index 3d9ae36150..43736191d5 100644
+--- a/src/logging/virtlogd.service.in
++++ b/src/logging/virtlogd.service.in
+@@ -7,8 +7,7 @@ Documentation=man:virtlogd(8)
+ Documentation=https://libvirt.org
+
+ [Service]
+-EnvironmentFile=-/etc/sysconfig/virtlogd
+-ExecStart=@sbindir@/virtlogd $VIRTLOGD_ARGS
++ExecStart=@sbindir@/virtlogd
+ ExecReload=/bin/kill -USR1 $MAINPID
+ # Loosing the logs is a really bad thing that will
+ # cause the machine to be fenced (rebooted), so make
+diff --git a/src/remote/libvirtd.service.in b/src/remote/libvirtd.service.in
+index 7f689e08a8..239beeced9 100644
+--- a/src/remote/libvirtd.service.in
++++ b/src/remote/libvirtd.service.in
+@@ -22,8 +22,7 @@ Documentation=https://libvirt.org
+
+ [Service]
+ Type=notify
+-EnvironmentFile=-/etc/sysconfig/libvirtd
+-ExecStart=@sbindir@/libvirtd $LIBVIRTD_ARGS
++ExecStart=@sbindir@/libvirtd
+ ExecReload=/bin/kill -HUP $MAINPID
+ KillMode=process
+ Restart=on-failure
+diff --git a/tools/Makefile.am b/tools/Makefile.am
+index 613c9a77f0..224b511074 100644
+--- a/tools/Makefile.am
++++ b/tools/Makefile.am
+@@ -339,15 +339,6 @@ install-data-local: install-init install-systemd install-nss \
+ uninstall-local: uninstall-init uninstall-systemd uninstall-nss \
+ uninstall-bash-completion
+
+-install-sysconfig:
+- $(MKDIR_P) $(DESTDIR)$(sysconfdir)/sysconfig
+- $(INSTALL_DATA) $(srcdir)/libvirt-guests.sysconf \
+- $(DESTDIR)$(sysconfdir)/sysconfig/libvirt-guests
+-
+-uninstall-sysconfig:
+- rm -f $(DESTDIR)$(sysconfdir)/sysconfig/libvirt-guests
+- rmdir $(DESTDIR)$(sysconfdir)/sysconfig ||:
+-
+ EXTRA_DIST += libvirt-guests.sh.in libvirt-guests.init.in
+
+ install-initscript: libvirt-guests.init
+@@ -362,8 +353,8 @@ uninstall-initscript:
+
+ if LIBVIRT_INIT_SCRIPT_RED_HAT
+ BUILT_SOURCES += libvirt-guests.init
+-install-init: install-sysconfig install-initscript
+-uninstall-init: uninstall-sysconfig uninstall-initscript
++install-init: install-initscript
++uninstall-init: uninstall-initscript
+ else ! LIBVIRT_INIT_SCRIPT_RED_HAT
+ install-init:
+ uninstall-init:
+@@ -394,12 +385,12 @@ EXTRA_DIST += libvirt-guests.service.in
+ SYSTEMD_UNIT_DIR = $(prefix)/lib/systemd/system
+
+ if LIBVIRT_INIT_SCRIPT_SYSTEMD
+-install-systemd: libvirt-guests.service install-sysconfig libvirt-guests.sh
++install-systemd: libvirt-guests.service libvirt-guests.sh
+ $(MKDIR_P) $(DESTDIR)$(SYSTEMD_UNIT_DIR)
+ $(INSTALL_DATA) libvirt-guests.service \
+ $(DESTDIR)$(SYSTEMD_UNIT_DIR)/libvirt-guests.service
+
+-uninstall-systemd: uninstall-sysconfig
++uninstall-systemd:
+ rm -f $(DESTDIR)$(SYSTEMD_UNIT_DIR)/libvirt-guests.service
+ rmdir $(DESTDIR)$(SYSTEMD_UNIT_DIR) ||:
+
+diff --git a/tools/libvirt-guests.service.in b/tools/libvirt-guests.service.in
+index 491ca62138..f0f417bffb 100644
+--- a/tools/libvirt-guests.service.in
++++ b/tools/libvirt-guests.service.in
+@@ -10,7 +10,7 @@ Documentation=man:libvirtd(8)
+ Documentation=https://libvirt.org
+
+ [Service]
+-EnvironmentFile=-/etc/sysconfig/libvirt-guests
++EnvironmentFile=-/etc/libvirt/libvirt-guests.conf
+ # Hack just call traditional service until we factor
+ # out the code
+ ExecStart=@libexecdir@/libvirt-guests.sh start
+diff --git a/tools/libvirt-guests.sysconf b/tools/libvirt-guests.sysconf
+index 669b046507..45b0b9ea46 100644
+--- a/tools/libvirt-guests.sysconf
++++ b/tools/libvirt-guests.sysconf
+@@ -1,3 +1,10 @@
++#
++# Warning: This configuration file is only sourced by the systemd
++# libvirt-guests.service unit. The coresponding openrc facility is in
++# /etc/init.d/libvirtd and /etc/conf.d/libvirtd
++#
++
++
+ # URIs to check for running guests
+ # example: URIS='default xen:///system vbox+tcp://host/system lxc:///system'
+ #URIS=default
+--
+2.19.2
+
diff --git a/app-emulation/libvirt/files/libvirt-5.0.0-fix-paths-for-apparmor.patch b/app-emulation/libvirt/files/libvirt-5.0.0-fix-paths-for-apparmor.patch
new file mode 100644
index 000000000000..ca9f952a8234
--- /dev/null
+++ b/app-emulation/libvirt/files/libvirt-5.0.0-fix-paths-for-apparmor.patch
@@ -0,0 +1,110 @@
+From 563706143779166624812b3faf498d869f5dd383 Mon Sep 17 00:00:00 2001
+Message-Id: <563706143779166624812b3faf498d869f5dd383.1547196492.git.mprivozn@redhat.com>
+From: Michal Privoznik <mprivozn@redhat.com>
+Date: Fri, 11 Jan 2019 09:41:06 +0100
+Subject: [PATCH] gentoo: fix paths for apparmor
+
+Signed-off-by: Michal Privoznik <mprivozn@redhat.com>
+---
+ src/security/Makefile.inc.am | 10 +++++-----
+ src/security/apparmor/libvirt-qemu | 2 ++
+ ...bvirt.virt-aa-helper => usr.libexec.virt-aa-helper} | 4 ++--
+ src/security/apparmor/usr.sbin.libvirtd | 6 ++++--
+ 4 files changed, 13 insertions(+), 9 deletions(-)
+ rename src/security/apparmor/{usr.lib.libvirt.virt-aa-helper => usr.libexec.virt-aa-helper} (93%)
+
+diff --git a/src/security/Makefile.inc.am b/src/security/Makefile.inc.am
+index b24cdfd083..ae8e979b84 100644
+--- a/src/security/Makefile.inc.am
++++ b/src/security/Makefile.inc.am
+@@ -36,7 +36,7 @@ EXTRA_DIST += \
+ security/apparmor/TEMPLATE.lxc \
+ security/apparmor/libvirt-qemu \
+ security/apparmor/libvirt-lxc \
+- security/apparmor/usr.lib.libvirt.virt-aa-helper \
++ security/apparmor/usr.libexec.virt-aa-helper \
+ security/apparmor/usr.sbin.libvirtd \
+ $(NULL)
+
+@@ -90,7 +90,7 @@ endif WITH_SECDRIVER_APPARMOR
+ if WITH_APPARMOR_PROFILES
+ apparmordir = $(sysconfdir)/apparmor.d/
+ apparmor_DATA = \
+- security/apparmor/usr.lib.libvirt.virt-aa-helper \
++ security/apparmor/usr.libexec.virt-aa-helper \
+ security/apparmor/usr.sbin.libvirtd \
+ $(NULL)
+
+@@ -110,11 +110,11 @@ APPARMOR_LOCAL_DIR = "$(DESTDIR)$(apparmordir)/local"
+ install-apparmor-local:
+ $(MKDIR_P) "$(APPARMOR_LOCAL_DIR)"
+ echo "# Site-specific additions and overrides for \
+- 'usr.lib.libvirt.virt-aa-helper'" \
+- >"$(APPARMOR_LOCAL_DIR)/usr.lib.libvirt.virt-aa-helper"
++ 'usr.libexec.virt-aa-helper'" \
++ >"$(APPARMOR_LOCAL_DIR)/usr.libexec.virt-aa-helper"
+
+ uninstall-apparmor-local:
+- rm -f "$(APPARMOR_LOCAL_DIR)/usr.lib.libvirt.virt-aa-helper"
++ rm -f "$(APPARMOR_LOCAL_DIR)/usr.libexec.virt-aa-helper"
+ rmdir "$(APPARMOR_LOCAL_DIR)" || :
+
+ INSTALL_DATA_LOCAL += install-apparmor-local
+diff --git a/src/security/apparmor/libvirt-qemu b/src/security/apparmor/libvirt-qemu
+index eaa5167525..9be50bbbe0 100644
+--- a/src/security/apparmor/libvirt-qemu
++++ b/src/security/apparmor/libvirt-qemu
+@@ -87,6 +87,8 @@
+ /usr/share/AAVMF/** r,
+ /usr/share/qemu-efi/** r,
+ /usr/share/slof/** r,
++ /usr/share/seavgabios/** r,
++ /usr/share/edk2-ovmf/** r,
+
+ # pki for libvirt-vnc and libvirt-spice (LP: #901272, #1690140)
+ /etc/pki/CA/ r,
+diff --git a/src/security/apparmor/usr.lib.libvirt.virt-aa-helper b/src/security/apparmor/usr.libexec.virt-aa-helper
+similarity index 93%
+rename from src/security/apparmor/usr.lib.libvirt.virt-aa-helper
+rename to src/security/apparmor/usr.libexec.virt-aa-helper
+index de9436872c..99ab4ea527 100644
+--- a/src/security/apparmor/usr.lib.libvirt.virt-aa-helper
++++ b/src/security/apparmor/usr.libexec.virt-aa-helper
+@@ -1,7 +1,7 @@
+ # Last Modified: Mon Apr 5 15:10:27 2010
+ #include <tunables/global>
+
+-profile virt-aa-helper /usr/{lib,lib64}/libvirt/virt-aa-helper {
++profile virt-aa-helper /usr/libexec/virt-aa-helper {
+ #include <abstractions/base>
+
+ # needed for searching directories
+@@ -33,7 +33,7 @@ profile virt-aa-helper /usr/{lib,lib64}/libvirt/virt-aa-helper {
+ deny /dev/mapper/ r,
+ deny /dev/mapper/* r,
+
+- /usr/{lib,lib64}/libvirt/virt-aa-helper mr,
++ /usr/libexec/virt-aa-helper mr,
+ /{usr/,}sbin/apparmor_parser Ux,
+
+ /etc/apparmor.d/libvirt/* r,
+diff --git a/src/security/apparmor/usr.sbin.libvirtd b/src/security/apparmor/usr.sbin.libvirtd
+index f0ffc53008..8a402bd6ec 100644
+--- a/src/security/apparmor/usr.sbin.libvirtd
++++ b/src/security/apparmor/usr.sbin.libvirtd
+@@ -98,8 +98,10 @@
+ audit deny /sys/kernel/security/apparmor/.* rwxl,
+ /sys/kernel/security/apparmor/profiles r,
+ /usr/{lib,lib64}/libvirt/* PUxr,
+- /usr/{lib,lib64}/libvirt/libvirt_parthelper ix,
+- /usr/{lib,lib64}/libvirt/libvirt_iohelper ix,
++ /usr/libexec/virt-aa-helper PUxr,
++ /usr/libexec/libvirt_lxc PUxr,
++ /usr/libexec/libvirt_parthelper ix,
++ /usr/libexec/libvirt_iohelper ix,
+ /etc/libvirt/hooks/** rmix,
+ /etc/xen/scripts/** rmix,
+
+--
+2.19.2
+
diff --git a/app-emulation/libvirt/libvirt-9999.ebuild b/app-emulation/libvirt/libvirt-9999.ebuild
index c8b391fe4389..158a315e310e 100644
--- a/app-emulation/libvirt/libvirt-9999.ebuild
+++ b/app-emulation/libvirt/libvirt-9999.ebuild
@@ -124,9 +124,9 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
PATCHES=(
- "${FILESDIR}"/${PN}-4.5.0-do_not_use_sysconf.patch
+ "${FILESDIR}"/${PN}-5.0.0-do-not-use-sysconf.patch
"${FILESDIR}"/${PN}-1.2.16-fix_paths_in_libvirt-guests_sh.patch
- "${FILESDIR}"/${PN}-3.10.0-r2-fix_paths_for_apparmor.patch
+ "${FILESDIR}"/${PN}-5.0.0-fix-paths-for-apparmor.patch
)
pkg_setup() {