summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2020-05-06 22:41:29 +0200
committerRafael Martins <rafaelmartins@gentoo.org>2020-05-06 22:42:38 +0200
commitafc5a8a1615c69a60ede2576eb28c9972bf34e8a (patch)
tree91595f2a9b9d2e9ebc04f06f7c42dc9436f5e37e /app-emulation
parentacct-group/simplevirt: initial import (diff)
downloadgentoo-afc5a8a1615c69a60ede2576eb28c9972bf34e8a.tar.gz
gentoo-afc5a8a1615c69a60ede2576eb28c9972bf34e8a.tar.bz2
gentoo-afc5a8a1615c69a60ede2576eb28c9972bf34e8a.zip
app-emulation/simplevirt: use acct-group, remove longdescription
Closes: https://bugs.gentoo.org/694812 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Rafael Martins <rafaelmartins@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/simplevirt/metadata.xml3
-rw-r--r--app-emulation/simplevirt/simplevirt-0.0_p20181012-r1.ebuild (renamed from app-emulation/simplevirt/simplevirt-0.0_p20181012.ebuild)11
2 files changed, 3 insertions, 11 deletions
diff --git a/app-emulation/simplevirt/metadata.xml b/app-emulation/simplevirt/metadata.xml
index 25e89f9e5959..e45e3daf442e 100644
--- a/app-emulation/simplevirt/metadata.xml
+++ b/app-emulation/simplevirt/metadata.xml
@@ -5,9 +5,6 @@
<email>rafaelmartins@gentoo.org</email>
<name>Rafael G. Martins</name>
</maintainer>
- <longdescription lang="en">
- Simple virtual machine manager for Linux (QEMU/KVM)
- </longdescription>
<upstream>
<maintainer status="active">
<email>rafael@rafaelmartins.eng.br</email>
diff --git a/app-emulation/simplevirt/simplevirt-0.0_p20181012.ebuild b/app-emulation/simplevirt/simplevirt-0.0_p20181012-r1.ebuild
index 8f7c69b4bddc..45f5a524d281 100644
--- a/app-emulation/simplevirt/simplevirt-0.0_p20181012.ebuild
+++ b/app-emulation/simplevirt/simplevirt-0.0_p20181012-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -11,7 +11,7 @@ EGO_VENDOR=(
"gopkg.in/yaml.v2 v2.2.1 github.com/go-yaml/yaml"
)
-inherit linux-info golang-vcs-snapshot user
+inherit linux-info golang-vcs-snapshot
EGO_PN="github.com/rafaelmartins/simplevirt"
GIT_COMMIT="78d29d8fa11ce72af5f897430af7bb7d2947a32f"
@@ -30,6 +30,7 @@ KEYWORDS=""
IUSE=""
RDEPEND="
+ acct-group/simplevirt
virtual/logger
app-emulation/qemu"
@@ -37,12 +38,6 @@ CONFIG_CHECK="~TUN ~BRIDGE"
ERROR_TUN="CONFIG_TUN: Universal TUN/TAP driver required to setup bridge networking"
ERROR_BRIDGE="CONFIG_BRIDGE: 802.1d Ethernet Bridging required to setup bridge networking"
-pkg_setup() {
- enewgroup simplevirt
-
- linux-info_pkg_setup
-}
-
src_compile() {
pushd src/${EGO_PN} > /dev/null || die
GOPATH="${S}" go install -v -ldflags "-X ${EGO_PN}.Version=${GIT_VERSION}" ./cmd/... || die